Start a new topic

AR.ImageTrackable does not tracking reliably

Hi there,

I am initializing a VideoDrawable then an ImageTrackable in my AR world much in the same way as shown in some of the sample projects on GitHub.  The problem I am encountering is that although both are being properly created, it seems that the ImageTrackable's onEnterFieldOfVision and/or onImageRecognized methods are not being triggered reliably.  For some images it works great, the video is loaded no problem, and the video is overlaid nicely on the image.  For other images it simply does not overlay the video at all (and I can see from my debugging it does not call the onImageRecognized method) which would explain why I can hear the video but not see it.  One of the images in question is a 2 star, so I am not really sure how to remedy this situation.  Any suggestions would be much appreciated.


Additional Info: 

It seems as though when I run into this tracking issue, if I pull the image out of view, then back into view, the video will appear and snap on.  So it is almost as if the ImageTrackable's onImageRecognized method isn't being called initially...

Hello Matthew,

First of all, could you please provide some further details on the issue:
  • Which version of the SDK are you using?
  • Are you using the JS API?
  • Are you using any of our Extensions (Titanium, Cordova, Xamarin, Unity)? If yes, which version are you using?
  • What device does this happen with (os Version and model)?
  • Send a video so we can check how we can reproduce this issue

In addition, you could have a look at this documentation regarding Best practice for Image Targets.



Hi Eva, 

  • I am using version 7.0.0 of the SDK
  • I am using the Android JS API
  • Not using any extensions
  • Happening on a Samsung Galaxy S7 running Android 7.0 Nougat
I have attached a video showing the issue.  I forgot to turn on the sound but right after the "found" graphic is removed, the video starts playing and you can hear it, but as you can see you cannot see it until I move the card around quite a to get the ImageTrackable to enter the onImageRecognized state for the first time.  This image is a 2 star image as well.


Hello Matthew,

One problem could be the size of the video you are using, as normally this should not exceed 5MB. Could you please send your complete AR experience (.html, .css, .js files, assets, target images) so we can test internally?



For anyone else having this problem, and so that the Wikitude team knows what's going on:

I've been able to pinpoint the problem to the fact that the AR.ImageTrackable does not always enter the "onImageRecognized" event quickly enough.  From what I have experienced, there seems to be two "recognitions", one made by the AR.ImageTracker to actually identify the target image and one made by the AR.ImageTrackable to track the identified target image and place the drawable(s) on it.  This causes a delay sometimes when the AR.ImageTrackable does not pick up the image right away and the user has to move the camera around to get it to "recognize" it.

I have attached a screenshot to the pertinent example in the API Reference where the code workflow I am using is discussed.  I would provide my AR World to you Eva but it probably wouldn't be fruitful because there's a lot of back and forth communication between the native and non-native code in it, so it would not run for you guys without the entire project anyways.

Login or Signup to post a comment