Start a new topic
Solved

Sample Project: White Background

hey there, sorry for posting again ;)


I've imported the wikitude-plugin and exported it to ios explained as in the instuctions (https://www.wikitude.com/external/doc/documentation/latest/unity/setupguideunity.html#setup-guide-unity-plugin). 


The strange thing is, that the app does use the cam and tracks the image, but it doesn't render the actual camera footage. Compared to the youtube guide (https://youtu.be/iGySZp_fWHQ?t=332) there is no canvas in the scene and there is also no prefab for it to be found. (The camera-object doesn't have any children attached)


Do I have to fetch and project the cam-footage by myself or is this a bug? 


When I checked Unity 5.6 with SDK 6 it was working. The new version runs on Unity 2017.1 with SDK 7 on an OSX device.


thak you and have a nice day,

simon


image




2 people have this problem

Thanks, Alex. It's working great on my device. 

Hi, 


Are you also getting the white background when you are running on the device? The background is expected to be white when running in the editor.


Best regards,

Alexandru


1 person likes this

Hi, I'm getting a white background when I play the sample scenes. It was working fine previously with the older unity versions. Can you help me out?

Unity Version 2017.3.1f1

Wikitude - Version 7.2.1-7.2.0image


It worked for me!!! Thanks!!

"Hi,


It seems that Multithreaded Rendering is the cause for this issue. Until we find why this is not working, please disable it from Player Settings -> Other Settings tab.


Best regards,

Alexandru

"

 

Hi,


It seems that Multithreaded Rendering is the cause for this issue. Until we find why this is not working, please disable it from Player Settings -> Other Settings tab.


Best regards,

Alexandru


3 people like this

Hi, i have the problem with the white background


You have any solution?


I am using unity 2017.2.0f3

I unload wikitude 7.1 and after wikitude (beta)


thanks.


2 people like this
I can't make the sample working on Unity 2017.2. It worked normally on 2017.1.
The camera does not work and render a white screen. Is there particular setting to make it work ?


I tested the sample Instant Tracking scene picking.

@Richard Heasman

Does this issue happen with the our example app as well?


@Nicholas Tsaoucis

I tested on our devices and couldn't reproduce this issue using Unity 2017.2.0f2 and Wikitude 7.1.0 from the downloads page (not the beta page). Are there any error messages printed in the Android Studio console when you start the sample?

Regarding the watermark, please make sure that your license is compatible with 7.1.


Best regards,

Alexandru

the one under the beta tab seems to be working ok with unity 2017.1

however it doesnt seem to check the license key properly. The camera feed is showing, but its covered by the missing license key watermark.

i have the correct key entered in all the scenes on the wikitudesCamera prefab though

also, on the beta page it says it was built on the 13/9, on the release page it says its built on the 20/9

which one is the latest to test for the fix?

tested the new 7.1.0  with unity 2017.2.0f2 on android, it still has a white background. camera is not rendering at all.

Just tested on Unity 2017.2.0f2, Wikitude7.1.0


With metal enabled, upon calibrating the tracker our game softlocks in DoRenderOffScreenCamera


H, 


The 7.1.0 beta release available from our downloads page, in the Beta tab, should fix these issues. If you still have problems with camera rendering, please let us know.


Best regards,

Alexandru

Does this work for anyone on 2017.2 beta for android devices?

The changes to the iOS settings doesn't really help the android builds.

Im testing on an galaxy s7 with 7.1 using api min 19 and target 24


Hi,


I apologize for the inconvenience.

Since Unity didn't fix this issue yet in any of the 2017.1 updates or in the 2017.2 betas, we will release an update with a workaround soon, so that Metal will work again.


Best regards,

Alexandru

Login or Signup to post a comment