Start a new topic

Ionic Codova Build ios Error

 

ld: warning: Auto-Linking supplied 'MyApp/Plugins/com.wikitude.phonegap.WikitudePlugin/WikitudeSDK.framework/WikitudeSDK', file was built for unsupported file format ( 0x76 0x65 0x72 0x73 0x69 0x6F 0x6E 0x20 0x68 0x74 0x74 0x70 0x73 0x3A 0x2F 0x2F ) which is not the architecture being linked (arm64): MyApp/Plugins/com.wikitude.phonegap.WikitudePlugin/WikitudeSDK.framework/WikitudeSDK
Undefined symbols for architecture arm64:
  "_OBJC_CLASS_$_WTArchitectStartupConfiguration", referenced from:
      objc-class-ref in WTWikitudePlugin.o
      objc-class-ref in WTARViewController.o
  "_OBJC_CLASS_$_WTArchitectView", referenced from:
      objc-class-ref in WTWikitudePlugin.o
      objc-class-ref in WTARViewController.o
     (maybe you meant: _OBJC_CLASS_$_WTArchitectViewController)
  "_OBJC_CLASS_$_WTAuthorizationRequestManager", referenced from:
      objc-class-ref in WTWikitudePlugin.o
  "_kWTScreenshotSaveModeKey", referenced from:
      -[WTWikitudePlugin didReceiveDidCapturedScreenNotification:] in WTWikitudePlugin.o
  "_kWTScreenshotBundleDirectoryKey", referenced from:
      -[WTWikitudePlugin captureScreen:] in WTWikitudePlugin.o
      -[WTWikitudePlugin didReceiveDidCapturedScreenNotification:] in WTWikitudePlugin.o
  "_kWTUnauthorizedAppleiOSSDKAPIsKey", referenced from:
      ___34-[WTWikitudePlugin requestAccess:]_block_invoke in WTWikitudePlugin.o
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Wont complete the build, and I think it has to do with the architecture format. Does anyone no a solution?


Hi all,

We just released a solution to the problem a few moments ago. Please let us know if you still have issues installing the Wikitude Cordova plugin, thx!


Eva


 

Hi Sho,


This problem happens with the last version of the SDK if you try to install it with the "cordova plugin add" command (or if you try to install the plugin sample project as described in the documentation).


The reason for this problem is described here on GitHub


For this problem, the solution was for me to :

  1. Uninstall the plugin from my Cordova project :
     cordova plugin rm com.wikitude.phonegap.WikitudePlugin
  2. Download the wikitude cordova plugin from here :
    https://www.wikitude.com/download/
  3. Extract the downloaded archive
  4. Install the plugin from where I extracted this archive
    cordova plugin add /path/to/extracted/archive/


Hope that Wikitude can fix that soon, or change its documentation to better guide new user.


Have a good week-end,


Amaury.



I forgot to mention that this problem has nothing to do with the fact that you are using Ionic (in my opinion).

Hello Sho,

Officially Wikitude does not Ionic. Can you try and see if you can build your project without Ionic so that we can see if this is a Wikitude related issue?

Thanks
Eva

 

Hello Amaury,

Thank you for posting all this information and helping with our community. The post you added here explains why this problem occurs in the first time. We are already investigating it and will update the documentation so that the users can setup a Cordova project easily. Meanwhile, the workaround regarding this issue can be found here (again GitHub ;)

Thanks
Eva

 

Login or Signup to post a comment