Start a new topic

Wikitude Instant tracking Example "LOADING"

I have had a significant amount of trouble getting the 04_Instant$Tracking_3_Interactivity example working properly. 


Aside from external css files not loading intermittently (this has been a problem throughout my experience with wikitude - the files are all loaded from a server dynamically), --


The biggest issue seems to be an orange border surrounding the entire view. When I place my finger on a 3D object and drag upward instead of moving the object the entire view seems to slide up and the  word "Loading" is displayed at the bottom of the screen. Since I do not have any html that has a "Loading" text in the index.html file I assume it is the ADE.js that is adding this. I can't make it go away and it interferes with finger gestures. I am using your example straight out of the SDK. No changes whatsoever. 


Where is the documentation for this? 

How do I make the "Loading" text go away (or never show up in the first place)?

Why do I have so many problems loading external CSS files?


Thank you


Wilson.  


Hello Wilson,

I tested your project and the first thing I noticed is that you do not see the grid when you start the app. If the only change was the images then you should still be able to see the grid layout. Are you sure that there is no other change in your code?

Thanks
Eva

 

We are using iOS 10.3.2 on an iPhone. I should also mention that we are using Xamarin and the javascript SDK 6.X and using an exact copy of you Interactivity Instant Tracking example. When I hit the play button the furniture buttons come active, but all input to the screen stops. We only have this issue using Instant Tracking.


Could u try it with Xamarin?

Hello Wilson,



I just tried the Xamarin Component of the 7.0 release on an iPhone 6 running iOS 10.3.1 and did not encounter the issue you described. Our testing sheets also tell me, that we tested on the iPhone6+ for the release and didn't find anything wrong with instant tracking either.


Would you mind telling me which iPhone models exactly you can reproduce this issue on?


Also, since you refer it to be randomly failing: how frequently does this freeze occur? I generated about 100 models over 10 runs. Do I need to try more for it to likely happen?



- Daniel


Hello Wilson,



I tried the link you provided in the latest version of the Wikitude SDK sample app on two different devices and found it to be working. The only thing I noticed is, that there might be a significant delay when creating a model augmentation for the first time, because models are loaded when first instantiated. Considering that the files are being loaded remotely, this could take a while (depending on model file size and download speed of course).


Which devices did you encounter this issue on and which iOS version were they running?

Which version of the SDK are you using, exactly?


The devices I used are:

iPad mini w/ iOS 10.3.2

iPad Air 2 w/ iOS 10.2



- Daniel

See here: https://support.wikitude.com/support/discussions/topics/5000084056


A continuation of this thread. The problem has been narrowed down.



Hello Wilson,



I tried the unaltered instant tracking interactivity sample loaded locally and loaded remotely and found both approaches to be working. I can only repeat myself by saying, that loading 3D models from a remote resource might take a while, which, for the case of this sample, happens when instantiating them for the first time with the button on the bottom of the screen. So input will stop until the model has been fully loaded and created.


You could pre-load the models upon starting the application to have them cached already when instantiating them by adding the following lines of code at the beginning of the createOverlays function.

new AR.Model("assets/models/clock.wt3");
new AR.Model("assets/models/couch.wt3");
new AR.Model("assets/models/officechair.wt3");
new AR.Model("assets/models/table.wt3");
new AR.Model("assets/models/trainer.wt3");

You could also replace the models with images of small file size and check whether that changes anything about the behaviour you're experiencing.



- Daniel



Test devices were:

  • iPad Air 2 running iOS 10.2
  • iPad Mini 4 running iOS 10.2.1

Important amendment: I used the 6.1 Xamarin component for testing.

, I retested with 7.0 Xamarin 7.0 and we have the same issues. I’ll see if I can explain them here.

Using an iPhone with iOS 10.3.2

 

Note that everything I tried worked on the Android.

 

After hours of testing and trying things it appears the problem is with adding 3D objects dynamically and switching between Tracking and Initializing. When I load up the five enabled 3D objects in the CreateOverlays function and add them to the cam drawables they display immediately. (Loading remotely was not an issue). When a single 3D object is loaded in response to HTML buttons after in tracking mode it sometimes works and sometimes fails.  In fact it seems to get stuck and the screen receives no more input. This behavior as I said is random. I added logger statements in the event listenters for the onTouchStart event for the furniture buttons. (The buttons were originally transparent but I changed that css statement so I could see them). If I press them prior to going into tracking mode I can see my logger statements. When I press the Play button to enter tracking mode and then press a furniture button I sometimes see the logger statement in the handler. Other times the screen will receive no more input. Everything seems to stop. I added logger statements to the addModel function and the onLoaded and onInitialized events of the models. With the logger open and in tracking mode, I press a furniture button and nothing happens. Everything seems suspended. If however I click the X button to close the logger box all my logger statements in  the AddModel function and the Model initialized and loaded events fire and the 3d object is displayed. Again this behavior is random. It appears that a Tracker in Tracking mode interferes with the javascript for the experience when a model is added after the tracker enters tracking mode. This never happens if I have a fixed number of 3D objects and I load them prior to initiating tracking.

 

Please let me know if we can get to the bottom of this.

 

Thanks

 

Wilson

 

Important amendment: I just tested it on an iPad with 10.3.3 and it works flawlessly. It fails randomly on 3 different iPhones


thanks again


Wilson

Hi, I went back to to an exact copy your Instant Tracking Interactivity Example. We store our java script AR experiences in Azure Blob Storage.  I found one issue that was affecting both iOS and Android. Azure blob storage did not have a mime-type for the css files and as a result was feeding them to our app as text/html. Once I fixed that the Android version of our app using the Instant Tracking Example began working fine. However, we are still having problems with the iOS app using the same example files. One Instant Tracking is turned on, all inputs to the screen stop. It is intermittent tho. About every tenth time or so it seems work for a bit but very sluggishly. Then it usually crashes the app. We are testing with adequate wifi. We are taking the files from here: https://ar.azureedge.net/cc2efdca-f370-4615-a22a-c86db70cf3c5/index.html


You are welcome to try them from this link. Please any help would be greatly appreciated. We have a demo with a real estate client very soon and I can't have only Android working. Thanks for any help you can provide. 


I attached a copy of the files at the link provided above.

Wilson    

rar

Please find the files attached. The only thing changed are the button images from your original example. Run it is iOS or android. Click on a button. Drag the furniture item upwards. Note the "Loading" text and the entire view moves instead of the object

rar
(1.57 MB)
Login or Signup to post a comment