Start a new topic

Compilation error with Xcode 7.3 with Wikitude SDK 6.1


We are trying to compile an iOS App using Wikitude SDK 6.1. However there is an error NS_EXTENSIBLE_STRING_ENUM as highlighted in the attached screenshot. 

This is our environment

iOS Target 8.3

XCode 7.3

Wikitude SDK 6.1

Is Wikitude ISO SDK 6.1 compatible with xCode 7.3?


Good morning,


 has been introduced with iOS 10 and therefore Xcode8. Here are the corresponding release notes.

So you would need to update to Xcode8 to work with the 6.1 Wikitude SDK.

Kind regards



you should actually be able to simply remove the  


 from the header file if you would like to continue using Xcode 7 for now.

- Daniel

Login or Signup to post a comment