Start a new topic

Problem with Radar and Pointer

image

As shown in the above,my project has broken down, I can't solve the problem,I hope to get your help, thanks!




Hello Xinfei,

Based on the information you provided I would suggest that you see if the gyroscope and/or compass data are influenced by this AMAP plugin.

Thanks
Eva

 

at this point, we don't know yet the conflict between wikitude and AMAP are caused by wiki or by AMAP, and this is what we want to find out, based on the video and image we provide, can u tell us which part of wikitude is malfunctioning? or what underlying data is Radar using?  it is something relate to Radar and the pointer. thanks.

Hello Xinfei,

Unfortunately this is something that we cannot provide support for. Wikitude can only provide support for questions and issues directly related to Wikitude products and this is an issue caused by another plugin you are using, so my only recommendation would be to avoid using this plugin. As I am sure you can understand, we simply cannot provide support for all the plugins that don't interact as expected with our product, as this is something that the company providing the plugin should fix.

Thanks
Eva

 

it looks like AMAP API we r using affected certain parameter of both radar and the indicator, all GEO functions are messed up, they are at the wrong place and with wrong direction, but still seem reacted properly.  can you identify which part of the code / function  or underlying lib/ parameters are screwed up? any hint? thanks.

Hello Eva ,


You can see the following video, may be more aware of the problem.


https://www.youtube.com/watch?v=K0lC15GXIE4&feature=youtu.be


Thanks

Xinfei


Hello Eva ,

I have tried with your sample,  the radar and the pointer are displayed correctly.

For the radar and the pointers are broken, we have found that one of our third-party SDKs affects WikitudeSdk, but we do not know which parameters and calculations will affect this problem, and whether you can provide the problem Parameter name and other parameter information that you think will lead to this situation.


Thanks

Xinfei



Hello Xinfei,

Have you tried with our sample to see if the radar and the pointer are displayed correctly?

Thanks
Eva

 

Hello Eva,

 

I  try to upgrade SDK to 6.1 in my project,but it still can't  solve the problem, could you give me some other suggestion?


Thanks

Xinfei

Hello Xinfei,

You mentioned you are using SDK version 5.3.1 but since then, we have already launched version 6.1. So you could try with this latest release and see if you are still experiencing the same issue.

Thanks
Eva

 

Hello,

we are using wikitude 5.3.1, JS API. we used Unity as a plug in module in our app, but not the extension.

this happened on both IPhone 5 SE, OS: 10.2.1 and IPhone 6 plus, OS: 9.3.1,  


this happened when we upgrade our AMAP API to 5.0, which is a very common map API in china, before upgrade, everything is working fine. we have the android version app, using the same approach and setting, everything is working fine, this only happens on IOS version of our app.


thanks

Hello Xinfei,

Could you please provide the following information:
  • Which version of the SDK are you using?
  • Are you using the JS API?
  • Are you using any of our Extensions (Titanium, Cordova, Xamarin, Unity)? If yes, which version are you using?
  • What device does this happen with (os Version and model)?
  • Is this happening with the sample app or in your own app? If it happens with your own app, does the sample app work on your device?

Thanks

Eva

 

Login or Signup to post a comment