Start a new topic

3D Model with two light sources

We are having issues creating a 3D model with two light sources. 

3D model

The model (see above link) is created in blender based on this link

When looking at it in Wikitude Encoder I get dark sides

How can we fix this?



I believe that the forum posts below could help you with your issue:

If you still have issues then you could send over you .wt3 and .fbx files and we can have a look at them.




Here is the fbx model

3D model

As displayed the screenshot above it is not rendered correctly in Wikitude Encoder (latest version).

if you could help with this we would really appreciate it.


have you tried looking at the cube from the other side? 

Three of the faces are lit. Which is the expected behaviour of the FBX you provided. The light sources you have defined only illuminate these three and the ambient color is black.

It looks exactly the same in blender if you change the camera position to be on the other side of the cube.

I assume you intended to set the ambient color by adding the light source named "Ambient". This is, however, a point light source. You need to actually set the ambient color, however that may work in the modelling software you are using. In Blender, for example, the ambient color is a property you can set on the material of your cube.

- Daniel

(28.5 KB)

Could you edit the fbx model to add this effect. We cant get it to work.

Good morning,

I'm afraid all I can offer is guidance on how to do it. Unless there is a malfunction with the SDK or the encoder you can demonstrate. Doing modelling or coding tasks is something we simply do not have the capacity to do. Even a small task such as this would violate the policy and set a bad precedent.

Here's how I changed the ambient light in Blender (v2.78):

  1. open Blender
  2. delete the default scene cube (DEL key)
  3. import your FBX file (File -> Import -> "FBX (.fbx)")
  4. select your mesh in the scene hierarchy view on the right
  5. switch to the "World" category using the buttons below the scene hierarchy view (fourth icon in my case, a stylised globe)
  6. below the preview on the right, you should be able to see a color picker for the ambient light
  7. switch to the material category (stylised as a circle with a checkerboard pattern)
  8. make sure the "Ambient" setting is set to a non-zero value
  9. export the scene to FBX again (File -> Export -> "FBX (.fbx)")

Most of what you need to do is depicted in the Screenshot I attached to my earlier post.

Please let me know if you need further assistance with this issue.

- Daniel

Login or Signup to post a comment