Start a new topic

How do I stop the cacheing when testing on official wikitude browser

I have testing my javascript on web server by official wikitude browser.

However, If I changed the script. It doesn't appear on wikitude browser.

Even I stop the wikitude browser, cache still works.

When I uninstall and re-install wikitude official browser, cache disappears charmingly.

I have set this in my script but in vain.

 <meta http-equiv="Pragma" content="no-cache">

 <meta http-equiv="Cache-Control" content="no-cache">

 <meta http-equiv="Expires" content="0">


I access the script on my server from normal browser, cache doesn't work.

Is there a good way to stop the caching when testing application??

I am using titanium module though, I guess it is not relevant in this case.

1 Comment

Hi daichi,

I'm a bit confused about your setup. You mentioned that you use our Wikitude Titanium module but also spoke about the Wikitude World Browser. When publishing an Architect World in the Wikitude World Browser, no Titanium module is necessary. Could you explain your setup a bit more detailed?

In case it turns out that you only use the World Browser: There is no setting to change any cache related settings. The World Browser should reload the Architect World without any caching every time you enter the World again from the main screen (pause/resuming the World Browser with the Architect World already running does not reload the World, thus don't picking up any changes you did to the files on the server).

Best regards,


Login or Signup to post a comment