Start a new topic
Solved

integrating wikitude in android app

 Hi,


I'm trying to integrate the wikitude javascript sdk into my android application, and I'm facing an issue:

- If I create a new project with just an activity and launch it, everything works as expected.

- Then I change this project to library, launch the same activity but from my application, I get a black screen: the webview isn't visible, and the camera doesn't seems to be started.

I checked application permissions, assets, libraries, everythiong seems OK.

In the logs I can see that the worldWasLoaded callback is called..

the only thing I see that differs from the working app is the log with TAG "k": "Problem loading resources. Switch to failsave state", but searching on this issue doesn't give me any entry point..


The only difference I have with my application is the presence of other native libraries, could this be the cause of my problem ?


Thanks


Oh! That was it !
As I'm still using eclipse, the assets folders weren't merged in my apk..
Now it works
thank you !

Laurent

Hi Laurent,


The log is shown when there was an issue when creating the splash animation or when creating the wikitude icon overlay. Those are shown when you don't have a paid licence. This issue could be caused if the icons for those overlays were deleted. 

You could check if your apk which is having the issue contains the following files:

  • assets/sdk_logo-1.png
  • assets/wikitude_icon.png

Best Regards,
Alex

Hi Alex,


The project where it happens is a big one, I will try to recreate the issue in a smaller project and send it to you.

Could you tell  me what the log "k": "Problem loading resources. Switch to failsave state" means ?


thanks,

Laurent

Hi Laurent,


I tried to recreate the issue by doing what you describe but was not able to get the black screen.

Can you send a minimal project where this issue is occurring to support@wikitude.com?


Best regards,

Alex

More information:
If I dump the view using DDMS, I can see in my working sample that the architectView framelayout contains a webview, a view and an imageview.
If I do the same thing in my appilcation (same activity), the framelayout is empty.

 

More informations:
- Im using the latest SDK (6.0)
- on a Samsung S5 neo with android 6.0.1
- my activity is based on the sample "3d object on target"

 

Login or Signup to post a comment