Start a new topic

Unity Error


I have problem when i import the sdk and i search forum of unity but there is no solution i need to help me to run wikitude sdk and fix this error  :

"the associated script cannot be loaded please fix all compile errors and assign a valid script"

i really dont know how to fix it
please guide me.

Hi Mohsen,

I do not exactly understand what your issue is. As a first step I would suggest that you go through our documentation and then download our sample app so you can start from there.



I really thanx about fast response. i have this problem with every sdk when i import.


Can you please check if there are any other messages printed to the console?

Does this also happen when you open the example project provided in the zip file?

Thank you,


Hi, thanx again.
I really don't know what happen when i talk to you.
but its fixxxxxxxx after 3 weeks.
for your question 2 : No, when i create a new project and import package sdk i saw that error.
but when i save and open that project again the error gone right now.


The problem is that you are using an older version of Unity and some of the samples that we ship are not compatible with it.

If it's possible, please upgrade to a newer version, preferably 5.3 or newer. If not, try to delete the CameraSettingsController.cs script and the errors should be gone. Only the last sample will not work after this change.

Best regards,


thanks a lotttt.
I already have 3 version of unity,4 , 5  and 5.1 not work .
but to advise you right now i install Unity 5.5.1f1 its okkkkk.

Really greatful Alexandru.


Login or Signup to post a comment