Start a new topic

Wikitude SDK - Trying to find out where you are


I'm curently trying to create my own AR app with POI for a school project, so I used the Android Studio SDK.

The problem is that I get a " Trying to find out where you are" error message when I launch my app.

My location service is enabled and my app doesn't appear in "Recent Location Requests" setting.

Here is the error I get (I use the screen from a previous topic I found).

And because I'm not confident about my project structure, here it is:


Don't hesitate to ask me questions for further details, and, please,pardon my English as it's not my mother tongue.

My mistake, It worked now , 

THANK you Théo , I have been struggling with this problem for like 20 days , I'm so grateful .

No problem! Hope you'll manage to create what you wanted to do ;)

I have the same issue... it always appears "trying to find out where you are". 
Can you tell me your steps to make the app work?


Hi Théo, i copied your project and tried to run but i get unable to resolve symbol AppCompactActivity, so i copied all the code into a new project file and the problem solved. but i get the same problem you faced before which is "Trying to find out where you are". Can you please guide me where you solve it? Thanks

Hello Luis,

Did you also try with our sample to see if it is working? Please read the whole forum post and you will find the answer here.



Hi Eva,

I am new to android and wikitude, I am working on application which uses wikitude sdk to augment POIs.

1. I made my own app, now I want to use wikitude functionality in it.

2. I made changes in manifest and gradle, included library for using wikitude.

3. I created assets folder and pasted the folder from wikitude SDK samples, named POI with labels.

Now my app is running, activity for wikitude is loading, camera is working, 

problem is i am getting symbol showing "trying to find your location".

All permissions are given, internet is on but still.

Please tell me did i need to make any changes in code or i skipped any step.

The sample app you have provided is working fine on the same setup.; Please respond urgently as I am facing a deadline and found no other place to resolve this issue.

Hello Théo,

did you solve the problem?

I have the same problem, would appreciate it if you tell me what to do.

Didn't solved it entirely, did another post on the support but get no answer :(

We get some better results while trying to add our own location data with the Google API.

The first of us who find give it to the other :) 

Hello Theo,

This message is shown when your location can not be fetched as needed. The "i" icon Trying to find out where you are means the app is waiting for location info. If it keeps showing that, it may be because your GPS is not open or you are testing in house and sometimes that blocks/affects the signal.

Please make sure that you have the location services on for the sample app. The location service has to be authorized by the user (so you can check your phone settings for the app if the location service is enabled to the specific app). For the location handling and the correct set-up please check the set-up guide to make sure you have everything done correctly. And you can also check the implementation and documentation for the POIs samples.

Finally, this could also happen because of specific requirements that your device fail to complete. You could try our sample app with several phones and see if this is happening with other phones as well. The minimum requirements that a device should fulfill are:
1. Compass
2. GPS and/or networking positioning
3. Accelerometer


Thanks for your fast answer!

My GPS is enabled and I'm in a big town so no problem about the signal.

As I said, the app is not requesting to access the location service, so I can't authorized it especially.

I tested it with differents phones (Samsung Galaxy S6 included) so requirements are fine.

Thanks again,



Could you please provide the following details:

- Which version of the SDK are you using?
- Confirm that you’re using the JS API
- Are you using any of our Extensions (Cordova, Xamarin, Unity)? If yes, which version are you using
- what device does this happen with
- is this happening with the sample app as well? If it happens with your own app, does the sample app work on your device.

In general this error message indicates that the location of the user can't be fetched and some permissions or setup for GeoAR is not done as expected or you're trying on a device without the needed sensors.

Thx and greetings


Sure, once I find a solution i will tell you.

but could you please tell me how did you add your own location data?

I got some problems with this sometimes. It just depend from my connection to GPS network. Try it outside (it really doesn't work well inside buildings :/ )

Thank god, someone with the same issue as me, I've been stuck on this for a month and a half, and was not able to get a solution from the support team. I am currently downloading the source code to test it, hope it was a problem on my behalf. Thanks Théo!! :)

Login or Signup to post a comment