Start a new topic

Wikitude 3D Encoder showing only one entity


I am having issues in importing models from AutoCAD to the Wikitude 3D encoder. The models are exported in FBX format and are correctly viewable in the FBX Autodesk Review software. However, when they are opened within the encoder I receive two error messages:

Invalid Polygon Index

No Material Assigned

The encoder then shows just one of the subentities of the model, e.g. a cylinder, but totally ignores all of the rest.

I am attaching the fbx file. Thank you in advance for your time!

(123 KB)

It often happens that the FBX export from CAD programs does not assign material parameters to the geometry. 

However, for rendering 3D model exported the materials are required, since they define the appearance of the objects in the scene. 

Autodesk's FBX Review renders it with a default material to come around this shortcoming. But nevertheless the material definitions are missing in the fbx file.

Maybe you can find some options in your fbx exporter to add the materials or you can open the fbx file in another 3D modeling tool, like Maya, and manually set the appearance properties all scene objects. 

Thank you very much for your quick reply.

I have tried by manually applying materials but, even though the only object being displayed is actually doing so with the new material, the other meshes in the fbx export still do not show at all and the warnings stay the same.

I am attaching the new FBX as well. I have no idea what I have done wrong. Isn't it possible for the encoder to apply a default material as well?

The Wikitude3dEncoder is just a converter.
The rendering should be ok if you specify the materials for all model parts in your fbx. 

Sorry, even applying the materials led to the same result. I have no way to inspect the fbx to see what is wrong. I am marking the thread as solved though since I have switched to another SDK.

Thanks again for the help!
Login or Signup to post a comment