Start a new topic

Getting Wikitude 6 Example to run on IOS

Hi there,

I was excited to download and try out the new SLAM system in Wikitude 6. Unfortunately the system crashes on me with the following error when I run the application.

dyld: Library not loaded: @rpath/WikitudeNativeSDK.framework/WikitudeNativeSDK

  Referenced from: /var/containers/Bundle/Application/6150BBE9-DA46-4D0F-AC94-C619C3B327D7/

  Reason: image not found


I'm using Unity 5.4.3 on OSX 10.12.2, and Xcode 8.2.1.  I tried on an iPhone 6 and iPad Air 2.  I didn't change any of the Build Settings in Unity or Xcode.

I'm sure this is something simple but it's not a great first impression (as a potential customer of Wikitude).

I'm still very keen to look at the system ASAP as I'm evaluating various AR systems for one of my clients (who is on a tight timeframe).

Many thanks


1 Comment


When building for iOS, the Xcode project needs some modifications, which can be found in this section of the documentation. Specifically, this error happens because the WikitudeNativeSDK framework was not added as an Embedded Binary. These changes only need to be made once, as long as the Xcode project is not recreated from scratch.

Best regards,


Login or Signup to post a comment