Start a new topic

Xamarin POI sample not working saying "trying to find out where you are"

Hello guys,

I'm trying wikitude for a while now, and i already had some 2d and 3d AR objects made. But i started working on the Points Of Interest sample and i have no clue what i'm doing wrong or i have something setup wrong because i already tried a lot to get it working so i hope you guys could help me out. I am using android and the test phone is a google nexus 5x (with a simcard)

Ok so here it comes, i'm trying to get the first piece of the POI sample and it doesn't do very much except for showing "trying to find out where you are" i did some logging here and there but as it turns out it doesn't even reach the locationChanged function. Somehow i have a feeling the function isn't even called.

The logging i can retrieve:

[libEGL] called unimplemented OpenGL ES API

[libEGL] validate_display:99 error 3008 (EGL_BAD_DISPLAY)

[VideoCapabilities] Unrecognized profile 2130706433 for video/avc

[VideoCapabilities] Unsupported profile 4 for video/mp4v-es

[Choreographer] Skipped 38 frames! The application may be doing too much work on its main thread.

[cr_BindingManager] Cannot call determinedVisibility() - never saw a connection for the pid: 699

[chromium] [] Failed to locate a binder for interface: autofill::mojom::PasswordManagerDriver

[cr_BindingManager] Cannot call determinedVisibility() - never saw a connection for the pid: 699

i know i don't have very much to go on but i hope you can maybe help me out here

And before i forget i have given the application the following permissions:







This is the startupConfiguration (i also tried the tracking2d):

new StartupConfiguration(Constants.WIKITUDE_SDK_KEY, StartupConfiguration.Features.Geo)

the requiredFeatures:

StartupConfiguration.Features.Tracking2D | StartupConfiguration.Features.Geo;

I think this is about it because the code what is left is untouched. I hope it's enough tho help me out and a thank you in advance!

Greetz Niels

1 Comment

Hello Niels,

This message is shown when your location can not be fetched as needed. The "i" icon Trying to find out where you are means the app is waiting for location info. If it keeps showing that, it may be because your GPS is not open or you are testing in house and sometimes that blocks/affects the signal.

Please make sure that you have the location services on for the sample app. The location service has to be authorized by the user (so you can check your phone settings for the app if the location service is enabled to the specific app). For the location handling and the correct set-up please check the set-up guide to make sure you have everything done correctly. And you can also check the implementation and documentation for the POIs samples.

Finally, this could also happen because of specific requirements that your device fail to complete. You could try our sample app with several phones and see if this is happening with other phones as well. The minimum requirements that a device should fulfill are:
1. Compass
2. GPS and/or networking positioning
3. Accelerometer

Login or Signup to post a comment