Start a new topic

iOS 10 and Ionic 2 - World loading but tracked elements do not (works as expected in Android)


I have installed this sample Ionic 2 Wikitude app which when installed on an Android device (running Android 7) works perfectly fine and as expected. When that same code is installed on an iOS device (running iOS 10), the Wikitude world launches and I can see the camera view with the Wikitude logo in the bottom left corner however none of the trackable elements are being picked up. 

Note: the interfaces on each device are different too. Please see below:


The logos in the bottom left are different and as you can see, when I load the same demo on both devices, the Android version displays the load message.

Please help! 

Many thanks,


I modified the starter app to use a IR world from the samples and it worked for me on iOS 10. 

Below you find the zipped source and the PDF with the targets. The IR world works with target 3 (the red car).

I will update the Github Repository ( with these sources soon.


(2.17 MB)

Hi guys,

Thanks for your time and help. I found the solution by comparing my current project to Philipp Breuss-Schneeweis' project. I installed this project on an iOS device which worked. The issue was with the loadARchitectWorld function. The fourth parameter I changed from ["geo"] to ["ir"]. 

Hopefully this will help someone else who is having the same problem! Thanks again.

Hi Ian,

Officially we don't support Ionic, so I can only provide you with some very basic support here.

It seems that the Architect World can not be loaded on the iOS device. Can you read through this starter app code and check what path/url is used to load the Architect World? Maybe it's a Android specific path.

Best regards,


Login or Signup to post a comment