Start a new topic

worlds not loading in iOS 10

Hi my app worked in iOS9. But I could not make it work in iOS10. I was told that I had to build a new project, and so I did. Firs I built  wikitude's sample app and ran it in my device (iphone 5c, iOS 10) and it worked. Then I created a new project following the guidelines of the documentation (, I added the sample code to this new project, built it and ran it on my device. It works, show the home page but when I tap any of the samples (image on target, multiple targets, and so on) nothing happens. I tryed to make the app open the world directly but it doesn't work either. Am I missing something? Regards:


P.S. I'm using Cordova 5.3.1

Ok, I saw some people having the same problem, that is, creating an app based on the wikitude samples app and the worlds not loading. I tryed what this user did in this thread

but it didn't work either. It seem that the function loadExampleARchitectWorld is called but loadARchitectWorld is not.  I installed the cordova file plugin and everything but it doesn't work. The strange thing is that I ran the sample app itself and it works

Hi Axel,

Did you already attach the Safari Web Inspector to see which JS error you have?

Are you trying to load your Architect World from the application bundle or a server?

Best regards,


Hi Andreas, I'm loading the world from the bundle. I don't know if I was clear enough but I'm trying to build an app based on wikitude's sample app. So I know the worlds do work. I attached the Safari Web Inspector and it gave me no JS error. Terminal and it XCode threw an error when tapping in a link to a world, terminal it showed the text below, and the error Xcode gave I attached as an image:

Process 1263 stopped

* thread #18: tid = 0x51330, 0x1c3a6458 libsystem_kernel.dylib`__abort_with_payload + 24, queue = '', stop reason = signal SIGABRT

    frame #0: 0x1c3a6458 libsystem_kernel.dylib`__abort_with_payload + 24


-> 0x1c3a6458 <+24>: pop {r4, r5, r6, r8}

    0x1c3a645c <+28>: blo 0x1c3a6474 ; <+52>

    0x1c3a6460 <+32>: ldr r12, [pc, #0x4] ; <+44>

    0x1c3a6464 <+36>: ldr r12, [pc, r12]

XCode and the 

Ok, I did some more testing, including with an app I created from scratch, not using the samples, and the result was the same. I put some alerts and the crash happens when the wikitude plugin object callls loadArchitectWorld. I mean, the object is indeed created, the callback onDeviceSupported is called, but when it tries to load the world it crashes. It seems to me like a path problem but of course I'm not sure, otherwise I wouldn;t be posting here, isn't it? REgards:


Hi Axel,

You now mentioned that your app is crashing which makes sense in an iOS 10 environment. You need to specify the 'NSCameraUsageDescription' key in your applications .plist. This is required in iOS 10+ and can not be done by the Wikitude SDK. You can refer to our example app creation script or e.g. this link for more information how to specify this key.

Best regards,


Thanks Andreas, that totally nailed it! I'm Marking the post as solved, I hope it helps other people in the future!

Login or Signup to post a comment