Start a new topic

Titanium First Launch at Production Level

Hi there, 

I have an issue with the App running first time after publishing it to the App Store.

I have installed the App on iPhone and iPad from TestFlight, I experienced the same bug where the AR won't work first time. After I terminate the app, and relaunch it, everything seems to be fine. I really need it to work first time.

I am running the following platform versions:

Titanium: 5.5.1

Wikitude: 5.3.1-3.0.0

All the platform used run the new OS system. 

Your help is much appreciated. 


Hi Sam,

Thank you for posting these details. In order for us to further investigate your issue, could you please tell me what you have implemented with your app?



Hi Eva,

Thanks for the reply. An overview on what the app recogonition on WTC files through Augmented Reality (IR). The source sequence of execution is as follows:

- Launch Dashboard.

- Dashboard contains a button "start". 

- When clicking, AR View is launched. 

AR View Launch Sequence: 

- wikitude.createWikitudeView().

- Augmented Reality Mode: IR

- attach AR World from URL. wikitudeView.loadArchitectuWorldFromUrl.

- The URL is pointing towards a HTML document named index.html.

- Attach Listener to the Wikitude URL.

- The AR source code and assets is located within the iphone folder.

- The index.html body tag contains source code for Tracker. 

Tracker World (Source code):

- loaded: true.

- rotating: false,

- init (constructor).

- createOverlays.

- createOverlays contains source code for tracker with pointing direction towards assets folder for the wtc file.

Your help is much appreciated. 

If you have any enquires please let me know.


Hi Sam,

Am I right that this only happens on iOS? If so, you can use a snippet like the following to request camera permission before the first Wikitude SDK usage.


Ti.Media.requestCameraAccess(function(e) {
			var theMsg;
			if (e.success) {
				theMsg = 'User granted access';
			else {
				theMsg = 'User denied access';
		    var alert = Ti.UI.createAlertDialog({
		        title: 'Camera request access',
		        message: theMsg


Best regards,


Hi Andreas,

Thanks for your reply, yes this occurs on the iOS platform for both iPhone & iPad. 

I'll attempt the snippet provided and I'll let you know if it has worked.

Thank you very much. 


Hi All,

I have done Andreas suggestion and it has worked. I have 3 Projects with Wikitude Module hence why I couldn't detect this. 

Anyone looking for a solution:

- Request for GEO Location permission.

- Request for Camera permission.

- Use callback function to handle the two dialogs appearing otherwise you will have dialogs stacking.

Thank you very much for your help. 

Have a great day.


Login or Signup to post a comment