Start a new topic

Problem creating a transparent video for wikitude

Problem creating a transparent video for wikitude

1 person has this problem

Hi Reza,

Unfortunately we do not have the video with the green background so I cannot provide it to you.

Thanks
Eva

 

Hi Eva I have done the exact instructions as documentation but result is different, so what could be the issue, either the green screen file that I am using OR tools that I am using to convert it. I've sent my files which is produce in each step so that you guys can help me to understand if tools are working or not, regarding to above answers, it seems you can't confirm that, so I need to investigate the issue by my self. There is a file in demo sources (same that the picture is attached in above answers) and you guys create that movie from a green screen file. If you can provide that original file, I am able to run my tools on that file and see if I get same result or not, If I get same results, my toolset is ok and there is an issue with my green screen file If I don't get same results, there could be an issue in my tool set, then I need to get back to you again to find out which step is not right. I hope I clarify it, please don't hesitate if you need more info.

Hello Reza,

I apologize but I do not exactly understand what you mean by saying "For my investigation to find what is wrong if is it possible to provide the original sample video with green background, then I can redo steps and I can divide and conquer the issue. " Could you please explain?

Thanks
Eva

Hey Eva Thanks for response, yes I repeated with different files and result is the same, For my investigation to find what is wrong if is it possible to provide the original sample video with green background, then I can redo steps and I can divide and conquer the issue.
By this way I can be sure that tools I am using are Ok or not?
Thanks for help

Hi Reza,

The only thing I can tell you is that the final video you created is not like the image I put in my post, so that means that there was a problem during the conversion of your video to a transparent video. Could you please repeat the steps again and make sure that the final video matches the one I posted?

Thanks
Eva

 

Hi Yes, I have read the documentation and I did what is mentioned there, also I read this thread before the final post says that "If you have access to Premier or Final cut this would be good." Since they are on mac I don't have access, also I provided step by step files to get help, since you have great experience you might see tge files and say hey this is what is missing or this is what is caused the issue.
Hello Reza,

Based on the videos you provided, they are not converted as they should be (see image below).

image


Please refer to the documentation section provided in the previous forum post by Nicola to see how the transparent videos should be like.

 

I attach files in different stage:  (3 of 4, 4 of 4)
File at step 3 (after saving as Prores is 64mb and site doesn't allow me to upload it here) you can download it via http://www.jarchee.ca/ar/3-minionsH264-nogreen-prores.mov

 

mov
OK
I removed green background with Easy Video Maker, and then convert it to Prores 4444, and still same,

I attach files in different stage:  (1 of 4, 2 of 4)

 

mp4
mp4
Oh I think I missed a step to remove green background before converting to Prores 4444.
I am going to find a software for that

 

Hey
I have exactly same problem, (I am using windows and I don't have access to Mac)
I used HandBrake to make my video H264 format
Then I used Bigasoft total video convertor to convert it to Prores 444
Then I used convert.bat
No error, but video still has green on top and completely white in the bottom

Any clue?

 


Hi,

From your videos it looks like the alpha channel was not stored correctly (because the lower part is completely white). If you have access to Premier or Final cut this would be good.

Greetings

Nicola

I did everything that the tutorial said, I made a video in a green screen, converted into apple prores 444, then into the <SDK> convert.bat and nothing... what program do I need to use or any advise?

Hi,

Did you follow the steps from this tutorial? The video before doesn't look correct - it seems that the alpha channel was not exported correctly.

Greetings

Nicola

 

Hi, I've been trying to convert a transparent video to a format that wikitude can accept for rendering, But the convert.bat does not work, can anyone help me.

 

I have this video, it's a H.264, 720p, baseline profile, etc. but when I execute a convert.bat I recive a video with a white space in the bottom.

"C:<SDK>WikitudeSDK_Android_5-3-0_2016-09-13_14-19-36Tools\Video\windows>convert.bat "C:\XXX\Desktop\Video before.mp4" "C:\XXX\Desktop\video after.mp4"   "

Thanks
Login or Signup to post a comment