Start a new topic

architect.js not found XDK

architect.js not found XDK

1 person has this problem


Hello everyone!

I just have started with wkitude, and i'm trying to run the example 1_Client$Recognition_1_Image$On$Target on XDK with no sucess.

Error message:
Failed to load resource: the server responded with a status of 404 (Not Found) https://www.wikitude.com/libs/architect.js

index.html code:

<!DOCTYPE HTML>

<html>

 

<head>

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

    <meta content="width=device-width,initial-scale=1,maximum-scale=5,user-scalable=yes" name="viewport">

 

<title></title>

<script src="http://debug-software.intel.com/target/target-script-min.js#Kee0thgAj3Zi5yuSItqDyWgkuXXadRj_XK4bsGoolf4"></script>

<script src="https://www.wikitude.com/libs/architect.js"></script>

<script type="text/javascript" src="js/ade.js"></script>

 

<link rel="stylesheet" href="css/default.css">

</head>

 

<body>

<div id="loadingMessage" class="info">Loading ...</div>

 

<script src="js/imageontarget.js"></script>

</body>

</html>

 

I have change the ade.js location.

What i have to do? Can someone help me?

Thanks,
João Pinho

Hi Joao,

Based on the error you receive I assume that there is a problem with where you have placed the architect.js file. Make sure that the paths that you are using are absolute paths (avoid ../) and are matching exactly.

Thanks

Even I had the same issue. I'm tryong from the example file from wikitude. 
Path is : https://www.wikitude.com/libs/architect.js

Error is: file not found, 

Hey Eva, I just wanted to try the examples on browser and as Joao and Lewis said the example has the code:

<script src="https://www.wikitude.com/libs/architect.js"></script>

 

included in the <head> of the html but opening index.html on a desktop browser we get the error:

GET https://www.wikitude.com/libs/architect.js 404 (Not Found)

which is odd since I expected it to work without any changes. The ade documentation here says the code is correct but doesn't seem to work or we are missing something.

Best regards

1 person likes this

Hello everyone,

Please make sure that you have download and using our latest Wikitude SDK 5.3 version (the whole package) and that you are testing on the device. This should solve the issue you are experiencing. Note that there is a new include for the architect.js to prevent mixed content errors in https environments that will work only for version 5.3. You can find further information on our documentation page under AR VIEW IN ACTIVITY. 

Thanks

Hello again Eva,

I have tested the examples on my Android device and everything works fine. What seems to be confusing us here is what the suggested workflow says:

CODE, TEST, DEBUG


Write your HTML, JavaScript and CSS using the text editor of your choice

Test in your desktop browser

Debug in your desktop browser using e.g. WebInspector

Test on a physical device

Debug on a physical device

Rinse and repeat


 

Steps one, two and three suggest that we can run the index.html of the examples in a desktop browser and expect it to work. So it makes sense to me that when I open the index.html of any example in my desktop computer using a desktop browser like Chrome, the example should load without any errors. What happens though is that we get that architect.js was not found and the example is not working.

H iEva,

I have the same issue. I follow documention and  https://wikitude.com/libs/architect.js is unreachable (timeout).

What is the right URL ?

best regards

Stéphane ADAM

 

 

 

Hi Stephane,

You have to download our latest Wikitude 5.3 version and make sure that you are testing on a mobile device and not on the browser.

Thanks

Hello again Eva,

the thing is that like I've stated in a previous message, the second step in your suggested workflow explicitly states that we should test on a desktop browser first. We can test the examples on a mobile device, but we need to test them on a desktop browser first.

Hi Thodoris,

replacing

<script src="https://www.wikitude.com/libs/architect.js"></script>

<script type="text/javascript" src="js/ade.js"></script>

 

by

<script src="architect://architect.js"></script>

<script type="text/javascript" src="js/ade.js"></script>

 

and taking ade.js from the last sdk archive and not from gitlab exemples (see this post https://support.wikitude.com/support/search/topics?term=Debugging+JavaScript+applications+using+ADE.js) works.

 

I've no error and objects properties are  viewable in ade tree.

best regards.

Stéphane ADAM

Thanks a lot Stéphane, switching to the correct ade.js now lets me sort of debug on a desktop browser.

 

Not sure why I should change the 

<script src="https://www.wikitude.com/libs/architect.js"></script>

with

<script src="architect://architect.js"></script>

the second one gives me 

GET architect://architect.js net::ERR_UNKNOWN_URL_SCHEME

on Chrome Console. Seems though that with the correct ade.js I can ignore that error even though I though we shouldn't get any error by default.

Hi Thodoris,

on device all architect:// protocol call are catch by wikitude module.

It's mandatory for having an AR object available.

Best regards.

Stéphane ADAM

 
Login or Signup to post a comment