Start a new topic

3D model works in encoder but distorted in real device

3D model works in encoder but distorted in real device

Hello, i am working with your cordova plugin these few weeks

It works well, but today i found some weird behaviour

I imported a fbx file to the encoder and it successfully previewed and exported to .wt3

However when I try it on a real device, it completely distorted (but seems the armour of the 3d model showed correctly..)

I have attached with the thread my .wt3 file, the screenshot of preview of it (on Wikitude 3d encoder), and how it distorted when tested in my real device,.

And for additional infomation when i import the fbx it says shape derformer not supported, i wonder if it relates? (actually I don't know much about 3D model, my partner gave me for the coding part)


Since I have open a thread, i want to ask another question..

What is the suggested or maximum vertices/mesh number and file size for the 3d models for Wikitude augmentation ? Let say I will need 20 of them in one World

Thank you very much for your help

Hello Leo,

Based on the screen shots you have sent over it looks like the dimensions of your 3D model are too big and this is why it is distorted when testing in a real device. When working with 3D models keep in mind that the size of the model should not exceed 5MB. The second thing is the dimensions of your model. You need to scale your model in a way that will fit the scene of your project. Could you please refer to this documentation here and see if your issue is fixed?

Thank you, 

Login or Signup to post a comment