Start a new topic

AR.Label not working

AR.Label not working


Hello!

We are loading  about 200 points (AR.GeoLocation) with markers(AR.ImageDrawable) and labels (AR.Label) and labels do not appear sometimes. When we use 2 points it works ok.

We use Trial version of WikitudeSDK. iphone 6, IOS 9.3, xcode Version 7.3.1 (7D1014) 

1. We use JS API - WikitudeSDK_iOS_5-2-0_2016-07-11_16-33-34 

2. Wikitude SDK 5.2.0 Release Date: 08.07.2016

3. It happens with sample app and our own app. We use 5_ObtainPoiData_3_FromWebservicem (in our app we just changed marker images). 

We use this code to call JS from ViewController:

 

        NSError *error;

        NSData *jsondata = ;

        NSString *jsonstr = ;

        

        NSLog(@"%@",);

        NSString *callmethod = ;

        ;

 

 

Where jsonstr is our json pois data. 

Hi,

Thx for reaching out. Can you please provide the following details:

 


- Which version of the SDK are you using? 

- Are you using the JS API or any of our Extensions (Titanium, Cordova, Xamarin, Unity)? If yes, which version are you using

- is this happening with the sample app or in your own app? If it happens with your own app, does the sample app work on your device.

- Send steps to reproduce this issue

- Send the complete AR experience as zip file (incl. the html, css, js files, assets)


 


Since you already sent an email to info@wikitude.com I would like to ask you to stick to one channel support please.

Thx and greetings,

Eva

Hi Yuliya,

I just tested from the file you sent over the project 5_ObtainPoiData_3_FromWebservicem on iPhone 6 and it was working fine. One your previous post you mentioned that you were having problems when loading 200 POIs. However, the project that you told me to test loads 20 POIs. I would however suggest that you limit the amounts of POIs you are loading to a max lower number like 50. Having 200 POIs in one camera view could cause problems with labels being overlapped. Regarding the other forum post that you have created regarding problems with rendering, is it for the same project that you have sent over here?

Thanks 
Login or Signup to post a comment