Start a new topic

Use of unresolved identifier 'WTFeature_Geo'

Use of unresolved identifier 'WTFeature_Geo'

Dear Wikitude support team,

I'm in the process of setting up the Wikitude SDK JavaScript API iOS (version 5.2.0) with my first iOS project (Xcode version 7.3.1), using the setup guide you have provided. 

I'm really excited about your tool being the potential solution for all AR applications, and looking to start funded project soon. However, I'm really encountering numerous issues from the start, and would hope that you can assist me (continuously and with good availability from your support staff) throughout the endeavour of learning your tool so that I really make your tool the choice for all AR solutions and application development. 

I added all the frameworks and dynamic libraries as per the instructions and created the WTArchitectView and WTNavigation properties no problem, no errors. So it shows the imports from the framework were successful.

 In the section of the code to initialize an instance of the type WTArchitectView, i.e. this section on your setup guide:

 - (void)viewDidLoad { // ... other initialization code ... NSError *deviceNotSupportedError = nil; if ( ) { // 1 self.architectView = ; self.architectView.delegate = self; ; ; } else { NSLog(@"device is not supported - reason: %@", ); } // ... continue initialization ... }

In this statement below: 

- (void)viewDidLoad { // ... other initialization code ... NSError *deviceNotSupportedError = nil; if ( )

I got the error:- 

Use of unresolved identifier 'WTFeature_Geo'

And I'm facing the same error with WTFeature_2DTracking

For the line below:

self.architectView = ;

I'm getting the error:- 

Type of expression is ambiguous without more context

And finally for the line below:

NSLog("device is not supported - reason: ", )

I'm getting the error:- 

Use of unresolved identifier 'localizedDescription'

It's worth noting that I'm using the equivelant of your code in the guide in swift (code below). This is not an issue with swift because the rest of the code has worked fine thanks to the ObjC - Swift bridging method which one of your staff support members (Martin Lechner) has recommended in a previous post: I was able to declare the ViewController subclass as WTArchitectViewDelegate, and create WTArchitectView and WTNavigation objects, which have all been recognised by the compiler. There was no complain or any errors. So it shows the bridging of ObjC and Swift has worked. However, I'm not sure why the compiler is complaing that constants WTFeature_2DTracking and WTFeature_Geo are not recognised/declared, even though they're declared in the WTArchitectView.h which I have imported in the Bridging-Header.h file, and hence the WTArchitectView object was created without any issues!! Below is my equivelant in swift code:

class ViewController: UIViewController, WTArchitectViewDelegate {

    @IBOutlet var architectView: WTArchitectView!

   weak var architectWorldNavigation: WTNavigation!

    override func viewDidLoad() {



        var deviceNotSupportedError: NSError? = nil

do {

            if (try WTArchitectView.isDeviceSupportedForRequiredFeatures(WTFeature_Geo | WTFeature_2DTracking)){

                // 1

                self.architectView = WTArchitectView(frame: self.view.bounds, motionManager: nil)

                self.architectView.delegate = self



            }else {

                NSLog("device is not supported - reason: ", );


            // ... continue initialization ...



Many thanks in advance


Hi hazzaldo,
Did you import the Wikitude SDK umbrella header (#import <WikitudeSDK/WikitudeSDK.h>) in the view controller that uses our WTArchitectView?

Best regards,

Login or Signup to post a comment