Start a new topic

Cannot launch ARchitect world in Cordova/Wikitude App

Cannot launch ARchitect world in Cordova/Wikitude App


It is few days I am struggling in creating my first simple Wikitude app, but cannot get the ARchitect work.

I did an infinite number of trials but none was successfull in fixing the issue that is preventing the camera to start.

 

My setup is as follows:

- I am using Cordova plugin

- Debug launching ADB via wifi on my Galaxy Note II - N7100 (Wikitude official App works fine)

- Cordova runs on a Windows 10 machine

 

I followed all the instructions to setup Wikitude, Cordova and Wikitude-Cordova plugin and added the licence key to WikitudePlugin.js

I tried to run the examples with no success, then I decided to try developing the easiest app I could. No success either.

Weinre is not helping in debugging.

 

What happens is that ARChitect just does not start, leaving a frustrating blank App below the app title.

This is my index.html

 

<!DOCTYPE html>

<html>

<head>

 

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<meta http-equiv="Content-Type" content="application/json; charset=utf-8">

<meta content="width=device-width,initial-scale=1,maximum-scale=5,user-scalable=yes" name="viewport">

 

<title>My ARchitect World</title>

<script src="architect://architect.js"></script>

 

<link rel="stylesheet" type="text/css" href="css/index.css" />

<script src="http://192.168.1.4:8080/target/target-script-min.js#anonymous"></script>

 

<!-- jQuery JS & CSS -->

 

<link rel="stylesheet" href="jquery/jquery.mobile-1.3.2.min.css" />

<script src="jquery/jquery-1.9.1.min.js"></script>

<script src="jquery/jquery.mobile-1.3.2.min.js"></script>

 

</head>

<body>

 

<script type="text/javascript">

WikitudePlugin.loadARchitectWorld("world/theWorld.html");

</script>

 

<div id ="header-status" data-role="header" data-position="fixed" data-theme="a">

<h2>Test</h2>

</div>

 

</body>

</html>

 

 

Can you help me in understanding what is wrong?

I am losing my sleep on this!

Hello Dario,

Can you please follow the instructions on these forum posts above and see if they help you fixing your issue?

1. Can't load an architect world with location on iOS

2. AR.loadArchitectWorld('my/path.html') doesn't load world

Thanks!

Hello Eva,

thanks for the answer. I am afraid no success,

Following your advice I tried different ways of referencing the path, but no success. Files are reachable, but it is apparently linked to the fact that 

<script src="architect://architect.js"></script>

is not leading to the expected result, and it does not open the camera.

Any advice?

 

Dario

Hi Dario,
From your first post, it seems that your .html/.js code might miss some lines in order to make our plugin work. I'm not sure what's behind the js file located at http://192.168.1.4:8080/target/target-script-min.js, but from what I see in your .html script tag, it might not be the key problem.

Can you please refer to our Cordova example application. The .js file does all the steps you need to make in your application to include our Cordova plugin. The key steps are:

* Create an instance of our Cordova plugin: app.wikitudePlugin = cordova.require("com.wikitude.phonegap.WikitudePlugin.WikitudePlugin");

* Load an Architect World: app.wikitudePlugin.loadARchitectWorld(function successFn(loadedURL)

* everything else is optional/depending on your Architect World/For better user feedback

For now I guess you simply missed the first point.

Best regards,

Andreas
Thank tou very much for your support, finally I were able to start the architect world thru loadARchitectWorld call. Apparently there were two WikitudePlugins.js in the platformandroid subfolder structure and I pur the licence key in the wrong one.

In the end I added the licence key everywhere (3 places in total) and now it works.

Still no success in launching architect://architect.js bit this sounds to be a different issue.

I thank you once again for tour help.

Dario

Hi Dario,
You don't need to/can't `launch` architect://architect.js. This file will be provided by our SDK at runtime. You don't need to worry about this. Please also note that this file is only available withing the web view that is part of our JS SDK (often also referred to as Architect).

Best regards,

Andreas
Login or Signup to post a comment