Start a new topic

Duplicate Files Error

Duplicate Files Error

I am using android studio with the Epson Wikitude Sdk. When I run the app, it gives me an error saying there are duplicate files.I have gone through all of my files and do not see any duplicates. When I take the wikitudesdk.jar file out of libs it has duplicate dependency errors. Perhaps I have the wrong dependencies? Any help would be greatly appreciated! Thanks




Error:Execution failed for task ':app:transformResourcesWithMergeJavaResForDebug'.
 > Duplicate files copied in APK sdk_logo-1.png
  File1: C:Users\myusername\AndroidStudioProjects\Test2\app\libs\wikitudesdk.jar
  File2: C:\Users\myusername\AndroidStudioProjects\Test2\app\libs\wikitudesdk.jar



Build.Gradle File:
apply plugin: ''


android {
    compileSdkVersion 23
    buildToolsVersion "24.0.0"


    defaultConfig {
        applicationId "com.example.pmbi002.test2"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), ''


dependencies {
    compile fileTree(dir: 'libs', include: )
    testCompile 'junit:junit:4.12'
    compile(name: 'wikitudesdk', ext: 'jar')
    compile ''
    compile ''


repositories {
        dirs 'libs'




Hello Mariah,

The problem here is that you are including the wikitudesdk.jar twice. 

compile fileTree(dir: 'libs', include:)

compile(name: 'wikitudesdk', ext:'jar')

If you remove one of them then this should fix your problem.

I appreciate your assistance. I removed the line "compile(name: 'wikitudesdk', ext:'jar')" and it fixed that error, but when I run the program I get the following error:

Could not identify launch activity: Default Activity not found
Error while Launching activity

I have included my manifests below if that is helpful. Thanks!


<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android=""

<uses-permission android:name="android.permission.INTERNET" />
<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
<uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
<uses-permission android:name="android.permission.ACCESS_GPS" />
<uses-permission android:name="android.permission.CAMERA" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
<uses-feature android:name="" android:required="true" />
<uses-feature android:name="android.hardware.location" android:required="true" />
<uses-feature android:name="android.hardware.sensor.accelerometer" android:required="true" />
<uses-feature android:name="android.hardware.sensor.compass" android:required="true" />
<uses-feature android:glEsVersion="0x00020000" android:required="true" />

<activity android:name=".MainActivity" android:configChanges="screenSize|orientation">
<action android:name="android.intent.action.MAIN" />

<category android:name="android.intent.category.LAUNCHER" />
</activity><!-- ATTENTION: This was auto-generated to add Google Play services to your project for
App Indexing. See for more information. -->
android:value="@integer/google_play_services_version" />






The latest question/issue seems to related to Android directly and not to our SDK. Please refer to this stackoverlfow thread This should help you fix the issue.

Thank you! I appreciate all your guys help.
Login or Signup to post a comment