Start a new topic

iOS JavaScript API build warnings

iOS JavaScript API build warnings


Hi Charitha,
Thx for pointing this out. Do you also have some warnings mentioning iOS 8?

We will update our project settings and documentation for an upcoming release.

Please notice that we will drop iOS 7 support with the next major version of our SDK.

Best regards,

Andreas

Hi Wikitude devs,

We are using latest iOS JavaScript API (version 5.1.4) in our app and our application runs on iOS 7.0 and up. Wikitude iOS documentation also says wikitude framework supports iOS 7.0 and up. But, when we compile the app with wikitude framework, it gives 98 linker warnings. Here We copied some of them and it is something related to your deployment target (minimum deployment target may set to 7.1). So can you please work on this and fix these warnings and post a new buld.

ld: warning: object file (~/Classes/AppSupport/WikiTude/WikitudeSDK.framework/WikitudeSDK(PVRTError.o)) was built for newer iOS version (7.1) than being linked (7.0)

ld: warning: object file (~/Classes/AppSupport/WikiTude/WikitudeSDK.framework/WikitudeSDK(PVRTVertex.o)) was built for newer iOS version (7.1) than being linked (7.0)

...

 

ld: warning: object file (~/Classes/AppSupport/WikiTude/WikitudeSDK.framework/WikitudeSDK(lodepng.o)) was built for newer iOS version (7.1) than being linked (7.0)

ld: warning: object file (~/Classes/AppSupport/WikiTude/WikitudeSDK.framework/WikitudeSDK(JsonConverter.o)) was built for newer iOS version (7.1) than being linked (7.0)

ld: warning: object file (~/Classes/AppSupport/WikiTude/WikitudeSDK.framework/WikitudeSDK(TrackingModelConverter.o)) was built for newer iOS version (7.1) than being linked (7.0)


Thanks,
Charitha
Login or Signup to post a comment