Start a new topic

prevent model to be hidden

prevent model to be hidden

Hi there,

I'm trying to have a scenario where after recognizing a trigger once, I show a 3D model and then I don't hide it even if the trigger is lost. I skip the OnExitFieldOfVision() method but somehow the model gets sometimes lost (a.k.a. it exits the camera frustum I guess) if I move my device away and come back but sometimes it doesn't. It's a bit inconsistent actually. I'm not sure how to fix this issue, my guess is that the camera rotation gets usually updated once a trigger is lost/recognized and that messes up everything if I try to keep my model visible and not "hooked" to my trigger position. Thanks for your answer.

Did you enable the enableExtendedTracking flag of the AR.Trackable2DObject ?

Hi Roland,


thank you for your answer. No I didn't enable extended tracking. I noticed that it's available on my Trackable Behavior script attached to my tracker object. If I enable it I need to set size and element, but I don't really understand how it's used. 

If you don't use extended tracking, the augmented 3D model should disappear as soon as the tracked image gets out of the camera view. 

With extended tracking the position of the 3D model is no longer attached to the tracked image, but to the surrounding of the tracked image, visible in the camera view. 

There is an SDK Example showing a 3D model in extended tracking mode: SDK Example -> Client Recognition -> Extended Tracking

Hi Roland,

Thank you very much for the hint! Now it works fine. Why should someone not use the extended tracking by default? In the case the trigger image moves?

The positioning of the augmentation are different for "normal" and extende tracking.

With normal tracking the augmentation is always placed uppon the target. This works only as long as the target is within the camera image.

In extended tracking the pose is initialized with the target, but after that the position stays constant. Since the target is not used anymore after the initialization phase, the tracking works also if the target is out of the camera frame. 

Hi Roland,

the extended tracking works fine, that said I noticed that sometimes when moving the device away and then coming back, makes it so that the 3D model either doesn't reappear or sometimes it does but it has a weird rotation or slightly off position. Is there a way to improve this behavior? Thanks
Login or Signup to post a comment