Start a new topic

Using Native API with Javascript API

Using Native API with Javascript API

1 person has this problem

I am trying to use the Native API along with the javascript API.  With the native API I am using the 3D tracking feature.  And with the javascript I am implementing an ARchitect world using geoObjects.  

I had the Native API loaded in xcode and sucessfully got 3d tracking to work.  I then added the javascript API and also got the world up and running and I can see my geoObjects.  But now I can no longer access the 3d tracking.  3D tracking opens up and states that a tracking map is required and I must record one.  Once I click record the app quits with the following error... Which I can't seem to figure out.  Is it possible to use the Native API along with the Javascript API?


objc: Class WTRenderer is implemented in both /private/var/mobile/Containers/Bundle/Application/2BBF9AFB-B91F-4F8F-80F2-8226F32C7F44/ and /var/mobile/Containers/Bundle/Application/2BBF9AFB-B91F-4F8F-80F2-8226F32C7F44/ One of the two will be used. Which one is undefined.

2015-11-12 19:04:06.774 Wikitude -: unrecognized selector sent to instance 0x15d25650

2015-11-12 19:04:06.777 Wikitude *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-: unrecognized selector sent to instance 0x15d25650'

*** First throw call stack:

(0x2637786b 0x37a76dff 0x2637d035 0x2637ab31 0x262aa2b8 0xd6461b 0xd64dd7 0x26a84577 0x26a7f7bb 0x26a7888d 0x2633a749 0x2633a205 0x26338b79 0x2628b1e9 0x2628afdd 0x2f52faf9 0x2a4f018d 0x9ad41 0x381a1873)

libc++abi.dylib: terminating with uncaught exception of type NSException

With further research into my issue, I was able to find the problem.  With the native iOS SDK, when the key 'NSLocationWhenInUseUsageDescription' is added to the info.plist the app fails with the error that I previously posted.  I am curious why this happens with the native SDK.  

I tested this on the Native Examples application and the same error is returned when trying to use the 3D Tracking example.

Hi Collin,
We never tried to load both of our SDKs in the same application.

The Native SDK does not include any GPS related functionality, so you don't need the .plist entry that contains the GPS access description.

Best regards

Login or Signup to post a comment