Start a new topic

cordova plugin with Xcode 7/iOS 9 failed to build

cordova plugin with Xcode 7/iOS 9 failed to build


Hi Nicola,

We have upgraded our version of Cordova as well as installed the latest Wikitude plugin, but we are still experincing this issue with the cordova build failing.

After upgrading the Wikitude plugin, we are now getting an error saying that the SDK is not licenced but with have specified the sdkKey in WikitudePlugin.js. 

Is there something we are missing in configuration of our project or perhaps need to update our licence key?

Please advise as soon as you can?

Thank you

Adrian

Just adding the plugin via Cordova CLI and trying to build gives some errors:

steps:

 

cordova create wikitudeTest com.wikitudeTest Wikitude Test

cordova platform add ios

cordova plugin add https://github.com/Wikitude/wikitude-cordova-plugin.git

cordova build ios

 

It produces this error:

Undefined symbols for architecture i386:

  "wikitude::sdk_foundation::impl::SDKFoundation& wikitude::sdk_foundation::impl::ServiceManager::getHostSDK<wikitude::sdk_foundation::impl::SDKFoundation>() const", referenced from:

      wikitude::sdk_core::impl::CalibrationManager::finishCalibration() in libWikitudeSDK_simulator.a(CalibrationManager.o)

      wikitude::sdk_core::impl::CalibrationManager::targetRecognized(wikitude::sdk_foundation::impl::BaseTracker&, wikitude::sdk_foundation::impl::RecognizedTarget&) in libWikitudeSDK_simulator.a(CalibrationManager.o)

  "wikitude::sdk_core::impl::ArchitectEngine& wikitude::sdk_foundation::impl::ServiceManager::getHostSDK<wikitude::sdk_core::impl::ArchitectEngine>() const", referenced from:

      wikitude::sdk_core::impl::CalibrationManager::finishCalibration() in libWikitudeSDK_simulator.a(CalibrationManager.o)

      wikitude::sdk_core::impl::CalibrationManager::targetRecognized(wikitude::sdk_foundation::impl::BaseTracker&, wikitude::sdk_foundation::impl::RecognizedTarget&) in libWikitudeSDK_simulator.a(CalibrationManager.o)

ld: symbol(s) not found for architecture i386

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

** BUILD FAILED **

 

my enviroment:

 

cordova version: 5.3.3

installed platforms ios 3.9.1

 

 

 

Try turning 'Enable Bitcode' off in your build settings. This combined with excluding ARM7S from your build architectures helped me out. Hope that works out!

Hello Jeremy,

thanks for your reply.

I followed your suggestion:

I've removed the plugin (actually i've deleted all the project folder), compiled without the plugin, removed bitcode and excluded ARM7S architecture.

but when I've reinstalled the plugin I got the same error again.

How can it be that a so expensive framework doesn't provide the right support?

 

Did anoyone succeed to solve this?

Edit: For reference: https://github.com/Wikitude/wikitude-cordova-plugin/issues/88

Hi Martin,

Did you checkout the latest Plugin version from GitHub and made sure you followed the instructions on the set-up and the issue report (e.g. disable bitcode).

Greetings

Nicola
Login or Signup to post a comment