Start a new topic

Wikitude SDK 4.1.1 crashes on LG G4

Wikitude SDK 4.1.1 crashes on LG G4


Sorry - Please create the folder as described in previous post or update to SDK 5 as an alternative. 

Best regards

Hi Nicola,

Thanks for your reply. The problem is once we create the arm64-v8a folder in our application, other 3rd party libraries will try to look for the 64bit version and hit exception as the other 3rd party libraries did not have arm64-v8a version.

Is there any way to make Wikitude SDK 4.1.1 to work on 64bit phones without creating the arm64-v8a folder?

Hi,

With SDK 4.1.1 you'll need to work with the following:

The problem is that our SDK is loading the 64bit library if needed for the system and other libraries might load the ?wrong? 32 bit version. A quick ?workaround? for SDK 4 from your end: in the JAR file copy the "armeabi-v7a? Library also in "arm64-v8a? so that the 32bit lib is loaded

Greetings

Nicola

Hi,

I found this thread and followed the solution given: https://support.wikitude.com/support/search/topics?term=UnsatisfiedLinkError+with+libarchitect.so+in+64+bit+devices+(Nexus+9)

Which is to extract the native libraries from the JAR file (which is actually a zip file), and put them into the 'libs' folder of your application.

My app is able to run Wikitude now, but it breaks other 3rd part library that does not have lib support for arm64-v8a.

From the reply from Wikitude says that Wikitude SDK 4.1 should have fixed the issue, and I'm already using SDK 4.1.1.

 

Hi Nicola,

Thanks for your reply.

The exception points back to the xml file (Line on: com.wikitude.architect.ArchitectView), but we are following the sample codes that came with the SDK 4.1.1.

 

<?xml version="1.0" encoding="utf-8"?>

<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"

    android:layout_width="fill_parent"

    android:layout_height="fill_parent"

    android:orientation="horizontal" >

 

    <com.wikitude.architect.ArchitectView

        android:id="@+id/architectView"

        android:layout_width="fill_parent"

        android:layout_height="fill_parent" >

 

    </com.wikitude.architect.ArchitectView>

 

</LinearLayout>

Hi,

Can you please check this stackoverflow post - this looks some of your definitions are missing.

Greetings

Nicola

Hi,

I am using Wikitude SDK 4.1.1 for Android. When I tested the AR in my app on all LG G4 devices, Wikitude crashes with the following exception. (Refer to logs below)

The LG G4 devices are running on Android 5.1.

Would appreciate help urgently as the app will be rolled out tomorrow.

Thank you.
Login or Signup to post a comment