Start a new topic

Exported 3d model(wt3 file) not loading up

Exported 3d model(wt3 file) not loading up


I have tried converting .fbx file to wt3 using wikitude 3D encoder. Conversion is completed without any error.

but when i am using this file for 3D rendering it is not loading at all. However,only default wt3 file car.wt3 already present in the SDK 

is loaded properly. Please suggest me over this.



Hi Manish,

Can you please send over the models with which you have issues to forum (at)

Thx and greetings


Hi Nicola,


I have attached some of the models which i have tried using in my app but app doesn't load with these 3D file, though there is no error.

If possible please send me a working wt3 file so that i can complete the testing on my app. Also, if you can figure out the reason for this issue please explain this to me.



Hi nicola,


I have also found these error while debugging. which may help you in analysing the issue.

09-08 15:02:16.823  23947-24644/com.wikitude.sdksamples E/Android Callback? Unsupported wt3 file format version

09-08 15:02:16.833  23947-24644/com.wikitude.sdksamples E/Android Callback? Corrupt wt3 file.

09-08 15:02:16.833  23947-24644/com.wikitude.sdksamples E/Android Callback? Preparing wt3 model failed.


I have tried converting several fbx files to wt3 file which is successfully done by wikitude 3D encoder. But it is still not recognized by SDK.



Login or Signup to post a comment