Start a new topic

ImageDrawable onClick problem with Android 5.x

ImageDrawable onClick problem with Android 5.x

Hi, I have a problem with ImageDrawable, in Titanium (SDK 3.5.0 GA).

I use the example "6_BrowsingPois_2_AddingRadar" on GitHub and this working successfully on Android and IOS platforms.

But when I update the component Android System WebView (V 42.0.2311.137) on Android 5.x, the click event of this code:

this.markerDrawable_idle = new AR.ImageDrawable(World.markerDrawable_idle, 2.5, {

zOrder : 0,
opacity : 1.0,
onClick : Marker.prototype.getOnClickTrigger(this)


does not work anymore. Even if semplify in this way:

this.markerDrawable_idle = new AR.ImageDrawable(World.markerDrawable_idle, 2.5, {

zOrder : 0,
opacity : 1.0,
onClick : function(){"Fire event");



The result does not change.

If I uninstall the update, the component returns to work correctly.

Thanks for the help.

Hi, which version of the Wikitude SDK are you using? This looks like an old problem, which was solved with the 4.0  release.

If you are not using the latest 4.1.1, I recommend you to update your SDK version.

We will investigate the problem internally as soon as possible.


I updated the Wikitude SDK at 4.1.1 relase, and my Android device at least Android System WebView (V 42.0.2311.138) relase.

However, the problem persists.

I attacced two file contains the code : 1) index_it.html, 2) marker.js

Thanks for the help.

Hi Antonio,

I tried the radar sample and your modified version on three devices (LG Nexus 5, Sony Z3, OnePlus One) all running Android 5.x and the latest Webview (42.0.2311.138), but couldn't reproduce the problem. 

What device are you using?
If you download the latest release package ( and install the sample apk (Examples/apk/WikitudeSDKSamples.apk), does the same problem occur on the radar sample?

Thank you and best regards,

Hi Simon,

My device is Moto x (2014) and when i install WikitudeSDKSamples.apk with my changes, it is working correctly.

However, when I copy and paste the sample code (6_BrowsingPois_2_AddingRadar) on my project, all works except the click. If I uninstall the Android System WebView update, the component returns to work correctly. 

I use the latest WikitudeSDK (v4.1.1) and TitaniumSDK v3.5.0GA.

I attached all my changes. Need you more information to help me to solve the problem?

Thank you,

P.S: I removed the references to my server from addingradar.js .

Hi Antonio,

I just tried to run your example, by replacing the original example folder with yours, unfortunately it doesn't load any POIs at all. 
Could you zip your entire project, including everthing I need to let run (wikitude plugin etc), and send it to In the mail please note that it should be forwarded to Simon.

Best regards,

Hi Antonio,

I just spoke to my colleague, he has some more questions for you:

What are the changes so that it works you mentioned in your last post? 

Is your app full screen? 

Does the click work if you click a little bit above or below the POI?

Thank you and best regards,
Hi simon,
Don't ask your answer, because I solved the problem.
My original project use this configuration in TiApp.xml:

uses-sdk android:targetSdkVersion="14"
but, it creates problems when the event occurs clicks (with learles Android system webview update).

When I changed the previous configuration in this:

uses-sdk android:targetSdkVersion="21"
The click event fired correctly :).

Thanks for your help and best regards.
Login or Signup to post a comment