Start a new topic

Titanium in Android Problem

Titanium in Android Problem

I run example  wikitude sdk with POIs example on Titanium 3.5.1 GA, and found the problem on Android 5.0+

on wikitude sdk 4.0.3 without ndk

POIs label show normally but when click on POIs label it not fired in event. if  fired event must clicked above of POIs label.

on wikitude sdk 4.1.0 without ndk and can't run and error meesage follow this

:  art: dlopen("/data/app/com.wikitude.titaniumsample-2/lib/arm/", RTLD_LAZY) failed: dlopen failed: cannot locate symbol "__exidx_end" referenced by ""...

:  TiApplication: (KrollRuntimeThread) Sending event: exception on thread: KrollRuntimeThread msg:java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__exidx_end" referenced by ""...; Titanium 3.5.1,2015/03/05 10:08,96875c9

:  TiApplication: java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__exidx_end" referenced by ""...

:  TiApplication:  at java.lang.Runtime.loadLibrary(

:  TiApplication:  at java.lang.System.loadLibrary(

:  TiApplication:  at org.appcelerator.kroll.runtime.v8.V8Runtime.loadExternalModules(

:  TiApplication:  at org.appcelerator.kroll.runtime.v8.V8Runtime.initRuntime(

:  TiApplication:  at org.appcelerator.kroll.KrollRuntime.doInit(

:  TiApplication:  at org.appcelerator.kroll.KrollRuntime$


I want to POIs label work fine from any version, What should I do?

Sorry about my English.



did you download the current sample code from Github?

Please also make sure you downloaded the newest module from our website (it is not in the Titanium store yet):

The sample code from Github will only work for the newest module. Please redownload the sample code and module from the links above and try again. Let me know if the problem persists.

Best regards,



I download sdk and example code from your url and set project from sample code in titanium studio again.

It doesn't work again just like previously.




I just had another look and was able to reproduce your problem. It seems the module does not run on Titanium SDK 3.5.1.GA.
It was built with 3.5.0.GA and doesn't even build anymore with 3.5.1.GA. We will look into this and will supply a new module in the future.

For now please switch to Titanium 3.5.0.GA in your tiapp.xml file. If you don't have 3.5.0.GA installed you can download it from here: Unzip the file and if you are on OSX copy it to "~/Library/Application Support/Titanium/mobilesdk/osx" or "C:Documents and Settings\All Users\Application Data\Titanium\mobilesdk\win32" on Windows.

Thank you and best regards,


I change Titanium sdk version, It does work.



we faced te same error, but we must use the 4.0.0 GA titanium sdk - (because of Appcelerator Platform features). We have the 4.1.0 Wikitude module and the error is the same.

What can we do about it?

We also have to use Ti SDK 4.0.0.GA

When can we have an actual compiled version of wikitude?

Hi Sebastian,

We will provide a new Titanium Module with our SDK 5 release. The extension releases (Titanium, Phonegap, Xamarin) will happen shortly after the native SDK releases.

I have added you on my list of people to inform when the release is ready.



Thank you very much

EDIT: Any thoughts when the new release is planned?

Hello Nicola, Please add me to the list too, im very interested to test the new Titanium Module with our SDK 5 release, Best Regards
Login or Signup to post a comment