Start a new topic

Xamarin.iOS for Visual Studio 2012

Xamarin.iOS for Visual Studio 2012


The only sample we have is the one on GitHub. Try to resolve the error messages. Each one suggests a possible solution to the problem.

We will provide a Xamarin Component early next year. Until then you need to work with both projects itself.

Best regards

Andreas

Hi,

I'm new to Wikitude SDK. I'm trying the example from https://github.com/wikitude/wikitude-xamarin. However, the assembly reference wikitude.iOS was missing from the solution files.

I could only find another reference "wikitude.SDK" (NOT wikitude.iOS) from the wikitude.sdk.dll file.

 

Can someone share something about building a successful example using Xamarin.iOS? Thanks.

Hi Sunny,
Our sample includes also the project for the iOS .dll. Have you tried to rebuild all projects in your solution?

Best regards
Andreas

I tried to clean and rebuild all two projects in the solution. However, I got the following errors:

1>BTOUCH : error BI0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com

2>------ Rebuild All started: Project: WikitudeSampleiOS, Configuration: Debug iPhone ------

2>C:Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.MonoTouch.CSharp.targets(32,2): warning MSB4011: "C:\windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.CSharp.targets" cannot be imported again. It was already imported at "C:\Users\Safilo\Downloads\wikitude-xamarin-master\wikitude-xamarin-master\source\samples\iOS\WikitudeSampleiOS\WikitudeSampleiOS.csproj (135,3)". This is most likely a build authoring error. This subsequent import will be ignored. 

2>  Generated session id: e9480c398767a6c785d1a075be2913b9

2>C:\windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1605,5): warning MSB3268: The primary reference "System.Net.Http.Primitives" could not be resolved because it has an indirect dependency on the framework assembly "System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.0". To resolve this problem, either remove the reference "System.Net.Http.Primitives" or retarget your application to a framework version which contains "System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".

2>C:\windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1605,5): warning MSB3268: The primary reference "System.Net.Http.Primitives" could not be resolved because it has an indirect dependency on the framework assembly "System.Runtime.InteropServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.0". To resolve this problem, either remove the reference "System.Net.Http.Primitives" or retarget your application to a framework version which contains "System.Runtime.InteropServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".

2>C:\windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1605,5): warning MSB3268: The primary reference "System.Net.Http.Primitives" could not be resolved because it has an indirect dependency on the framework assembly "System.Net.Primitives, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.0". To resolve this problem, either remove the reference "System.Net.Http.Primitives" or retarget your application to a framework version which contains "System.Net.Primitives, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".

2>C:\windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1605,5): warning MSB3268: The primary reference "System.Net.Http.Extensions" could not be resolved because it has an indirect dependency on the framework assembly "System.Net.Http, Version=1.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which could not be resolved in the currently targeted framework. ".NETFramework,Version=v4.0". To resolve this problem, either remove the reference "System.Net.Http.Extensions" or retarget your application to a framework version which contains "System.Net.Http, Version=1.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".

2>C:\Users\Safilo\Downloads\wikitude-xamarin-master\wikitude-xamarin-master\source\samples\iOS\WikitudeSampleiOS\ViewController\RecentUrlsViewController.cs(9,15,9,39): error CS0012: The type 'UIKit.UITableViewController' is defined in an assembly that is not referenced. You must add a reference to assembly 'Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065'.

========== Rebuild All: 0 succeeded, 2 failed, 0 skipped ==========

 

Not sure if it can be solved by adding the files to a new Xamarin template.

Is it possible to have a simple code snippet for me to start work with Wikitude on Xamarin.iOS? Thanks.

 

Best Regards,

Sunny

Hope to have the Xamarin component from Wikitude soon. Thanks.

The sample solution for the Wikitude extension currently is making use of iOS Binding Project, which is not working on Visual Studio. I have to build with Xamarin Studio on Mac.
Login or Signup to post a comment