Start a new topic

iOS SDK 4.0.2 examples not working

iOS SDK 4.0.2 examples not working


I just downloaded the latest iOS SDK (4.0.2) and tried out the examples. But the AR view shows with text "Unlicensed SDK" and no images are tracked for all the examples. Could anyone please help me?

Hi Vishnu,

You'll need to enter a Trail license key. Please find details on the trial key and where to enter it at this page.

I hope this helps.



But I'm not able to generate the trial license. The license generation page shows error.


Sorry for the inconveniences - there is a wrong link in the documentation. Here is the correct link:

We'll fix the documentation reference.

Thx and greetings



I have added image files to portal, generated wtc file and also added trail licence key but Still I can not recognoze any images

I have tried it in boath iphone 4s and iphone 5s

please help!!



When you switch the .wtc file in the sample app, to recognize your own images, please make sure you follow these steps:

Recognize your own images

Upload your images to the target management tool (log-in required)

Generate your target collection file (.wtc)

In your code create an AR.Tracker and load the target collection file from the previous step

Create an AR.Trackable2DObject and assign your targetName

Make sure that the targetName used with the AR.Trackable2DObject correspond to one of the target names in your target collection. You can also use a wildcard to match any target or only a specific subset of targets. Please refer to the AR.Trackable2DObject main documentation for more information about wildcards.

Should the problem persist, please provide us with the needed code snippets of the initalization of the Tracker and Trackable2DObjects and the .wtc file, so we can check on our end.


Login or Signup to post a comment