Start a new topic

Wikitude SDK Official examples not showing markers on Samsung Galaxy Tab 4

Wikitude SDK Official examples not showing markers on Samsung Galaxy Tab 4


I've installed the Official Sdk examples apk ( on a new Samsung Galaxy Tab 4 (SM-T535, android 4.4.2).

The default example app has been installed succesfully.

Opening the examples (E.G. POI related examples), the Cam activates succesfully, the bottom-center icon tells that the POI are loaded succesfully, but I can't see any markers in the World.

I've tried to build a custom little demo application with android following the tutorial, and the result is the same. 

Trying the examples (offical sdk and my custom app) on two phones (android 4.0.3 and android 4.4.2) everything works as expected.

Anyone could help me to understand the problem?

Thanks in advance




If you are seeing the "unlicensed SDK" watermark in your application, then you need a trial license for your SDK.

A license key is included in the source code of the sample application, if you are writing your own application, then you need another key. See for details, you can request a free trial license for your applcation.

HI Gabriele,

As I wrote in the previous post I'm talking about the official sdk examples.

They do not need registration. I've not rebuilt the example project. Just installed the apk

Talking about the sample that I've written from scratch, I've obtained a trial licence key.

I do not see any "unlicensed SDK" watermark. For my custom application I can see the "Trial" watermark.

As I said in my first post, the most important thing is that the same examples (the offical wikitude sdk samples apk and my custom apk) work succesfully on other devices.


I don't know much about the Samsung Galaxy Tab 4, I've read the specification online, but could not find any explanation for possible issues.

Are you sure that the magnetometer in your device is working? Can you check it with some "compass" application?
Have you tried restarting the device, or reinstalling the application?

I've tried to have a logcat launching the Official examples.

One error trapped is: 

E/mm-camera(  259): pproc_port_sink_check_caps_reserve:823> error because caps Type:1 not supported.

Added zip of logcat

Thank you for the feedback.

I've found an exception in your log:
E/ActivityThread( 8945): Performing stop of activity that is not resumed: {com.wikitude.sdksamples/com.wikitude.samples.SampleCamActivity}

This exception also occurred during our internal test, and we are already working on it, but doesn't affect the geo-location service.

I've also compared the specification on the Samsung web site with another model. It seems that the Galaxy Tab 4 (at least the model number SM-T535 NZWATTR which is currently sold in Austria) doesn't have a compass. Without that sensor, the device can only support vision-based AR worlds.

For reference, here is the comparison of the same 2 models on the Italian Samsung site:

According to the datasheets, the Galaxy Tab 4 has no magnetic field sensor.

Please check if the device has a compass, and if it's working.

Thanks Gabriele,

I've found this link:

does it mean that the device has compass sensor?

Now I'm out of office, I'll check soon on the owned device. I've a second new Galaxy Tab 4, I will check on it too.

I've found different version of the specification on various web sites, but the official specification (on doesn't report any compas (magnetic field sensor).

The link to the official Italian Samsung site also says the same (under "sensori"). Here is the comparison between the Galaxy Tab 4 and the Galaxy Tab S:

The Galaxy Tab 4 only has a Hall Sensor and an Accelerometer, no Magnetometer, no Gyroscope.

So, we can officially say that the galaxy tab 4 is not suitable for augmented reality :) ?

Could you explain better what do you mean for "Without that sensor, the device can only support vision-based AR worlds." 

I haven't found any working example in the sdk examples app.


Our SDK currently supports two different AR modes.

You can discover which mode is supported on a particular device by calling ArchitectView.getSupportedARModeForDevice()

Possible return values are:
- ARMode.IR -> Image recognition (in the sample application, the "IR" samples, section 1, 2, and 6 + the solar system demo 99.1)
- ARMode.Geo -> geo-location based IR (samples in the section 3, 4, 5 and solar system demo 99.2)

The target images for the IR samples are stored in a PDF file in the "assets" folder, together with HTML and JS code.

I've found this link that lists the device requirements:

Have you got a list of Android Tested Tablets and Smartphones with Full Wikitude Support?

Any suggestion?

Thanks again for your support.

We don't have a full list of supported devices, we are testing on some reference devices, by different vendors, with different Android versions. This includes:

- Sony Xperia Z1, and Xperia Tablet Z
- LG Nexus 4 and Nexus 5
- Samsung Galaxy S2, Galaxy S5, Galaxy Note 2 and Galaxy Note 10.1 (2014)
- HTC Nexus One and Desire HD

Login or Signup to post a comment