Start a new topic

Camera only show TRIALS word and no camera view

Camera only show TRIALS word and no camera view

3 people have this problem


Thanks. Will be downloading the phonegap version and will test on all of my devices. Will let you guys know if I run into any problem again.

Thanks again.

Hi, the patch fixed the camera issue for android device. However, currently, there is a problem that is in both OS, which is the POI, the Radar is not showing.
I did debug the process and found that it said in the ImageResource onLoaded event, that the image is loaded. But it's not showing up in the interface.

There are a few elements that is using AR.ImageResource, all those that use this class will not be shown in the interface. But the POI is there. because I did an alert when it's clicked, and it can respond to click.

Any help would be greatly appreciated!

Hi, does that happen with all your test devices? Is it our plugin sample application? Which sample are you trying?

If this happens with your code, can you send us some example HTML?

Hi,

Yes, it's happening on all my devices, iOS and Android alike.

Yes, I am using the example files for Phonegap plugin, specifically the Camera Capture with Browsing POIs

Here is the full source of the phonegap WWW folder
https://dl.dropboxusercontent.com/u/7374845/Wikitude_WWW.zip

Thanks a lot man.

There is something strange in your configuration, the standard sample application should not show the "unlicensed" watermark.

My suggestion is: try to download the sample application again from github (in a different directory), maybe you are missing some files.

Hi, I did try to go through the setup for phonegap app project and add plugin following the guide as per from http://www.wikitude.com/external/doc/documentation/latest/phonegap/setupguidephonegap.html

And I still the same issue as before and also it said unlicensed SDK. As for configuration, I dont think there is any configuration at all! Because all I did, was just putting the code together.

Please assist. thanks!

 

My bad, now the images show up correctly. And that's after I inserted a trial version sdk key. The confusion was at the WikitudePlugin.js where it said,
 

/**

*  This is the SDK Key, provided to you after you purchased the Wikitude SDK from http =//www.wikitude.com/store/.

*  If you're having a trial version, leave this string empty.

*/

 

So, I intuitively, left it empty.
But after I cross checked with the setup guide in the link from my last post. I realized, may be the developer didn't get memo on this.

 

Cheers.

I will work on it and will let you guys know if I go into any trouble again. Thanks a lot.

There is still a problem with screen capture, it doesnt work on Phonegap app (iOS and Android).
It works though on Native app (iOS and Android)

But I need a working screen capture version on phonegap. Please assist. thanks!

I tested the screenshot function on some devices, and couldn't reproduce your problem with the sample application.

On Android: if you are implementing the snapshot function in your own application, make sure that your application has the permission WRITE_EXTERNAL_STORAGE: the screenshot will be saved to file, and your application will receive an event "onScreenCaptured" with the file name as a parameter. The plugin sample application defines this function in the "index.js" file.

You can also define another callback function "onScreenCapturedError": you will get more information in case something goes wrong.

 

Man, I have the same exact frustration. The wikitude team must really have 1 more line of instruction in their "Getting started" page to say that you need to update the trial SDK key cause as the WikitudePlugin.js says to leave it empty. Please just update the comment there. It will resolve alot of unnecessary headache!

Hello guys!

I'm trying to run example apps on my EPSON BT-200 and have the same issue as described above - despite of camera view i can only see black screen. I have the last updated version, and non empty trial license key as an argument in the architect as described in the "setup project..." part. Did I miss something?

Kind regards

Marta

 

Hi.

Since the Epson BT-200 screen is transparent, you only see the augmentation and the camera frames are not rendered.

Hello there,

I feel sorry to re-open that ticket, but I encounter the same problem as the first one Soo How NG got. On my first trial app, i only get a black background and the trial word on the screen. It seems that the SDK is fully loaded, but i can't use my camera vision, any idea?

I run on Android Marshmallow (23) and id doesn't work, neither on android Kitkat (19). I tried it on the emulator and on my phone device, and I use the last version of the javascript sdk, the 7.0.0.

Thanks by advance,


Julien


1 person likes this
Hell Julien,

You cannot use the emulator for SDK versions prior to 7.0 since this is something that we have integrated with our SDK 7.1 version. Did you try with our sample app and still receiving the same error? Did you make sure that you have allowed camera permissions for our SDK?

Thanks
Eva

 

Hello again!

Thanks for answering that fast. I allowed camera permissions as the following screenshot can show you, but I didn't try with the sample apps. Gonna try it today.


image

Thx again,


Julien


I have the same problem as Julien, I have checked to see if the SDK Examples work and the camera works fine for them. Can't seem to pinpoint the problem. I have also used the PermissionManager to check for camera permissions and that hasn't helped. What would be the next step? 


Thanks, 


Tom

Login or Signup to post a comment