Start a new topic

Camera only show TRIALS word and no camera view

Camera only show TRIALS word and no camera view

1 person has this problem

Hi, I am using the example files to run on phonegap, but after the app started, the camera view is just pitch black with Trial words all over. I am using trial version with trial keys. Is there anything that I should do to solve this problem?


The "Trial" words indicate that you are using the SDK with a Trial license, so the behavior is on purpose in this regards.

However, the camera should still be on, even when in Trial mode. Did you try to restart your phone? Sometimes, certain apps don't properly release access to the camera after they have been closed. In this case, any access to the camera is blocked, even for other applications.

Please try to restart your phone and immediately afterwards start the example again.



Yes, thanks for the information.
However, after restarting the phone, the problem still persist. 
The camera is my android phone has asked for Camera and Geo Location permission. After that, it just show pitch black.

And at times, the POI would show up, but against black background.

On my iOS however, I am facing another problem, the camera however is working fine, but the POI is not showing up. There is an indicator at the bottom of the screen that tells you whether location has been detected and how many POI has been put into the World. But it just doesn't show up.

And another thing is that, the capture screen doesn't seem to work. I am using the example files from github, by the way.

We need some more information in order to help you regarding the rendering issues: Which Android/iOS device are you using and which OS version do they run?

I will have a look into the capture screen problem and reply to you as soon as possible.

Best regards


My iOS Device,

iPhone 4 - OS 7.1.2
iPad Mini - OS 7.1.2

Samsung Galaxy Tab 4 7.0 - OS 4.4.2
XiaoMi 3 - OS 4.4.2


Regarding the screen shot issue. I tried it on a iPhone 4 and it was working as expected. You have to accept the Camera Roll access so that we can save the screen shot.
Does the error callback is called?

On which device are you experiencing the screen shot issues?

Best regards


Actually, on all my devices, I can't take the screenshot. It didn't prompt me for Camera Roll access.
Is there anyway that I can send you my current phonegap files that you can verify for me? 

Because, I am really hitting a dead end here if the example files are not working out of the box.

Here is my phonegap files.


Hello, I am seeing this exact same issue running the Phonegap samples on Android. I have seen a couple of other posts about it as well.

I am building to a Nexus 4, using Phonegap/Cordova 3.5.0-0.20.9. I also tried the Xcode project to build to an iPad and things are working as expected. I get the same blank camera on Android doing a completely fresh project and plugin install.

I have also been developing a project using an mix of some of the older sample directories and my own code - this project has been working fine, and I have not been able to pinpoint a difference in Android configuration files. Not sure where else to look.



Me too, so now I resorted to using the native build for both Android and iOS.
And those examples are working as expected, only phonegap version is giving me critical problems where I can't find even a slight hint of what went wrong with my setup.

If you are like me, working against a tight deadline, I suggest you too, use the native version and not phonegap version.

I am also facing exactly the same issue.

And have a deadline to meet.  Expect the development team @ Wikitude to please provide a patch asap.

Device and problem are as listed:

Device : Samsung Galaxy S2

Android Version: 4.1.2

Problem : the camera only shows trials word and no camera view however the html is loaded in the background.


Device : Samsung Galaxy S4

Android Version: 4.4.2

Problem : the camera only shows trials word and no camera view however the html is loaded in the background.  The POI's are created and there is no error however they are not displayed on the screen.


Its the same app behaving differently on the two versions.

Hope we have a solution quickly.



Hi guys,

We are looking into this issue currently, but we don't have any ETAs yet. We will let you know once this is investigated.



An updated version of the phonegap plugin will be online soon.

In the meantime, you can solve the problem by downloading the official Android SDK 4.0.1 and replacing the wikitudesdk.jar file inside the plugin directory with the file inside the official SDK package.

Good news about the coming fix.

The wikitudesdk.jar file from 4.0.1 gave me build errors, however, I had a local version of 4.0.0, and using that I was able to successfully build the phonegap samples to my device - with a working camera.

Thanks for looking at this.

The new version has passed internal test and is now available for download.
Login or Signup to post a comment