Start a new topic

iOS changes are not reflected on compilation

iOS changes are not reflected on compilation

Hi there,

I have been trying since more than 2 days. I downloaded the latest ios sdk 4.0.0 and ran the examples. Having checked few examples, I tried to change the message or values inside the particular .js files but my changes are not reflected when i recompile the program with changes.

For example : i ran the example - 3_PointOfInterest_1_PoiAtLocation, and changed the text message of info icon.  

World.updateStatusMessage('1(one) place loaded');

Even when i tried to change the scale , rotation values of 3d model example, it never reflects when i run the code.

What can be the reason for this behaviour ? Am i missing somthing here ?

Thanks in advance for your help :)


Thanks Christian.

I found the similar thing while searching. It is due to the folder references created. I need to touch those files before compilation so they are considered new. So i need to set the "Run script" before compilation and need to clean project everytime before run.

The following run script should be set in Project Settings->Build Phases -> New Run script Build phases.

touch -cm ${SRCROOT}/ARchitectExamples


I guess that you need to clean your project before building and deploying it on your iOS device. Sometimes Xcode doesn't pack the changed resource files.
Someone postet a similar issue in this stackoverflow post.

Hope that helps,
Login or Signup to post a comment