Start a new topic

Whenever run the demo application,I am getting an error.

Whenever run the demo application,I am getting an error.


 

The library 'wikitudesdk.jar' contains native libraries that will not run on the device.

The following libraries were found:

 - libs/armeabi/libarchitect.so

 - libs/armeabi-v7a/libarchitect.so

 

Getting an error in Demo Wikitude project

I am using GT-N800 device.Sample apk run on device successfully.But whenever we run a sample project ,getting an error on console.

The error is below:

 

The library 'wikitudesdk.jar' contains native libraries that will not run on the device.

The following libraries were found:

 - libs/armeabi/libarchitect.so

 - libs/armeabi-v7a/libarchitect.so

Hi,

can you let us know more details about the nature of the error (which device are you using, exact error message). The information you provided is not enough to be able to assist you.

Please have a look at the very first step in the Android Setup guide of the Wikitude SDK documentation.

In Eclipse enter Preferences -> Android -> Build and ensure the option Force error when external jars contain native libraries is unchecked

Kind regards,
Andreas
Login or Signup to post a comment