Start a new topic

ArchitectWebView: ArchitectEngine: Can not project GeoLocation.

ArchitectWebView: ArchitectEngine: Can not project GeoLocation.



I have been trying to implement a simple app following the examples that comes with the SDK (4_ObtainPoiData_2_FromLocalResource),

but I'm having some problems. If I use the array data that comes with the example it works nicely, all the points appear in it's

correct position and any message is displayed. But when I change the array data with my on locations, all points appear in the

same position and a message is displayed in the console window (ArchitectWebView: ArchitectEngine: Can not project GeoLocation.).

I don't know why this is not working... I just change the value of latitude and longitude and the example stops working!?

I didn't find any information on google about this, even here on forum.


So if some one have this problem we could give me some light. I will be very glad :D.

Thanks in advance!


Example ArrayData:

var myJsonData =


My ArrayData:

var myJsonData = ;


There seems to be something wrong with your latitude/longitude or the locations are too far away to project them correctly. What location are you at? Make sure the locations you are using are close by < 50km to actually see them.

Thanks man! Some of the locations that we were loading from a webservice was to far away, and we were not checking that! xD


I am working on ARchitectExamples - "5_ObtainPoiData_1_FromApplicationModel". I am facing problem in showing POI markers. My app showing there are 4 placed loaded, but I can't see any POI markers there. When I run the app, I get these error messages "Wikitude SDK: ERROR -> connection could not be established" and "Wikitude SDK: ArchitectEngine: Can not project GeoLocation."

Here are the code for "didUpdateLocations" and "generatePois":

- (void)locationManager:(CLLocationManager *)manager didUpdateLocations:(NSArray *)locations {

    id firstLocation = ;

    if ( firstLocation )    {

        CLLocation *location = (CLLocation *)firstLocation;

        NSLog(@"Update Me %.8f , %.8f, %.0f m, %.1f m/s" ,location.coordinate.latitude, location.coordinate.longitude, location.altitude, location.speed);


        manager.delegate = nil;


        NSString *poisInJsonData = ;





- (void)generatePois:(NSUInteger)numberOfPois aroundLocation:(CLLocation *)referenceLocation {


    for (NSUInteger i = 0; i < numberOfPois; ++i) {

        NSString *poiName = ;

        NSString *poiDescription = ;

        CLLocationCoordinate2D locationCoordinate = CLLocationCoordinate2DMake(referenceLocation.coordinate.latitude + WT_RANDOM(-0.3, 0.3), referenceLocation.coordinate.longitude + WT_RANDOM(-0.3, 0.3));

        CLLocationDistance altitude = referenceLocation.verticalAccuracy ? referenceLocation.altitude + WT_RANDOM(0, 200) : -32768.f;       

        CLLocation *location = ;

        WTPoi *poi = ;





My coordinates are:  3.12744704 , 101.64308651, 77 m, -1.0 m/s

The data for poisInJsonData is: 



Best Regards,


Hi Vivian,
Have you tried out our latest SDK 5.1.1 release? All samples should now support iOS ATS and connect to the server correctly.
The message 'can not project GeoLocation' is shown if you try to show a poi which is not directly visible from your location, e.g. if it is on the opposite earths hemisphere.

Can you tell us your location where you run the example?

Best regards

Login or Signup to post a comment