Start a new topic

Telerik Platform

Telerik Platform

Has anyone successfully implemented Wikitude phonegap plugin on the Telerik Platform?  I feel like it should work given they are both leveraging cordova but I haven?t had much luck wiring up a simple example.


I have succesfully imported the plugin per the following document:

According to my Telerik helpdesk ticket, I can just start using the Wikitude API.  So I didn't need to modify the plugin.xml or add any includes to the index.html.

So I just added the following lines of code

onDeviceReady: function() {


    alert("Got To Here 1");
    app.wikitudePlugin = cordova.require("com.wikitude.phonegap.WikitudePlugin.WikitudePlugin");
    alert("Got To Here 2");


When compiling in the simulator, I get first alert but not the second and console logs display the following error:  Uncaught module com.wikitude.phonegap.WikitudePlugin.WikitudePlugin not found

When compiling and viewing on the device (since Telerik simulator does not support custom plugins), I get the first alert but not the second.


It simply appears to me that the plugin isn't being registered although it appears it's compiling.  I've found similar issues with other custom plugins where they claim that you need to do a cordova.define but didn't have much luck attempting that either.



i have same problem as you?

i installed cordova plugin + wikitude . and this is my error 

Uncaught module com.wikitude.phonegap.WikitudePlugin.WikitudePlugin not found at file:///android_asset/www/cordova.js:59

Has anyone successfully implemented?



yes sir.  we got it working.  not sure we ran into the same error that you did though.  The trick for us was to not use the version found in github but rather download from wikitude.  once we did that and dropped it into the telerik plugin directory, things started compling.  from there we just started slinging some code to leverage.  Not sure i helped...

Thank you very much

mr Heath Wilson.

can i have your email address?  my email is please add me.

I have not installed Telerik .i have installed cordova plugin and wikitude using npm  cli command.

but i ran into the same error that you did.

how can add wikitude plugin to cordova without having that error on complie?

Honestly, i'm not sure for we never went that route opting for Telerik Platform instead.  And yes, it took us a while to get it working.  And sadly, that was a year ago and I'm fuzzy on all the things we tried.  I seem to recall posting the solution somewhere for the interwebs have helped me a ton and I belive in returning the favor when possible.  Maybe telerik forum.  Have you tried downloading some of the examples on github that are already compliled and starting from there?




Login or Signup to post a comment