Start a new topic

architectView invokedURL is not getting called

architectView invokedURL is not getting called

Hi, Wikitude

I am now using iOS SDK for my research app. However, I am encoutering a problem regarding architectView invokedURL method.

I have included WTPresentingPoiDetailsARViewController in my own app, and I have my ARchitect world

set up on a remote server using the SDKexample "5_BrowsingPois_5_NativeDetailScreen".

I did set up the self.architectView.delegate = self; in -viewWillAppear method, somehow the viewcontroller

is not responding to the more button click. Could it be the reason that I have my ARchitect world placed 

on a remote server?





There should be no difference wether you load from the bundle or from a remote location.

Do you see any console output? What is the url requested and are you 100% sure that the relevant part is executed?

Yes, I added a line of "alert(architectSdkUrl);"in the .js file. When I press the more button, I got a response from my webservice of my www adress.

It seems somehow architectView invokedURL is not responding or not getting called properly. 

I will include some code example in this post, helping you to clarify what seems to be the problem.

On my AR viewcontroller, I have: 

- (void)viewWillAppear:(BOOL)animated




    self.architectView.delegate = self;


    // update the interface orientation in case of a change during poi detail presentation




- (void)architectView:(WTArchitectView *)architectView invokedURL:(NSURL *)url


    if () {

        NSLog(@"URL called");

        NSDictionary *parameters = ;


        if (parameters) {

            NSUInteger poiId = ;


            WTPoi *poi = ;

            if (poi) {


                WTPoiDetailViewController *poiDetailViewController = ;

                poiDetailViewController.poi = poi;






which is identical to the resource bundle. This view is the second view among the viewcontroller hierachy. In the first view, I have a uibutton which goes like this:

- (IBAction)moveToWikiTude:(id)sender {

    NSString* wikitudeURL = @"";

    NSURL *architectWorldURL = ;



The wikitude folder contains the source html file and the rest of .js file. 

That's pretty much how far I got right now. 

How does the function look like for the more button?

is it properly calling document.location = "architectsdk://markerselected"?

Is the delegate method not called at all? Please verify this with breakpoint and/or log output. I just want to make sure that this isn't the issue.

Did you try with the example world?

Yes, the more button looks exactly like that document.location = "architectsdk://markerselected". 

I did breakpointing and log output. Delegate method is not called at all. 

I tried with the exmaple world. It the work, but when I tried to  load the world from URL option within the SDK example

it didn't work again. 

Please check again if the sample is working for you and then follow these steps:

- copy all sample releated code to the server

- exchange the local loading of the sample with the URL pointing to your server

- Test and see if it is working, checking the console output for any errors or warnings

Important, please do not change anything so we can verify that the sample (js and native part) is still the same, which is working locally.
Login or Signup to post a comment