Start a new topic

PNG images not loading

PNG images not loading

I am getting the following errors while trying to load png images in AR view. 

ARchitect: Image (1): Unable to load.

ARchitect: Failed to load ImageResouce (1): Unable to load.

ARchitect: Image (2): Unable to load.

ARchitect: Failed to load ImageResouce (2): Unable to load.



No such issue when using jpg images! Please provide a solution asap. Thanks.

Hi Anand,

which version of the SDK are you using and which device are you trying to work with? We are not aware of any PNG related issues with the SDK.

Your device:
Your device OS:
Your Wikitude SDK version:

Hi Philipp

I am using the latest version (3.2.1). I am testing on iOS 7.0 and 7.1 devices.

Can you copy and paste the exact pieces of code where you are using that image plus both images (the working jpg and the not working png?)

Additionally please check the Sample App (first sample Image Recognition - Image on Target) whether it is running for you, as it also makes use of PNG images.

Even the default images in the assets folder are not loading up giving the same error for me. I am using the code from SDK examples project (4.1 application model). No such issues while running that project as well!

Do you mean that you see the very same error when using the code from the sample? What happens if you build and run the sample itself? 


Oops, I meant that there are no issues while running the sample project.

If I convert the same images to jpeg, then there is no problem. Only issue is with png images, including those in the assets folder (the default icons).

Can you copy the source code and paste it here - also it would be good to have the actual images (one working, one not working). If the data is too sensitive,  please send it via email to

Even if don't use my custom code and just load up the AR view with code from the examples project, its not working for me. I am using the AR world (4.1 application model). Even when I try to load up the default blue icon images in the assets folder, then too the same error is shown and the images are not loading. So all png image are having this issue.

Hi Anand,

we tested the sample app on iOS 7, using Xcode 5.1 and nothing seems to be broken here. Can you try the following in your environment.

* Load the sample app project into Xcode and build the entire project. Run it on your device and try sample 4.1 - does it show the same error?

As I have said earlier, there is absolutely no issue with the sample app. The issue is only when I run the AR in my app. I am using just the same code in the sample app, with the same framework and all. I am tearing my hair off with this. I tried loading the default icon images in the wikitude example assets folder, then tried with custom images as well, but nothing's working!


can you send us the link to your entire project to, which I will then receive. We will have a look then immediately. 

I will not be able to share my project code. But for the sake of sharing, I created a test project and put in the same code that I was using in my project and it has no issues! So the issue is only with my project. Maybe it has got something to do with project settings, I am not sure.
Login or Signup to post a comment