Start a new topic

wikitude plugin don't load

wikitude plugin don't load

note : am using free trail 

note2: i change   this._sdkKey = "";  to empty string as i shows .

Guessing from the little information provided:

Are you using Phonegap 3.3?

You probably will have load our plugin using the cordova.required function.

e.g. somewhere inside the index.js

app.wikitudePlugin = cordova.require("com.wikitude.phonegap.WikitudePlugin.WikitudePlugin")


have a look at our github sample at:
It already includes all required code to get it running.

yes am using phonegap 3.3 and ill upload my js and html file 

After I had a short look at your app.js file, it was clear what your problem is: It looks that you mixed code snippets from different applications.

Insode your onDeviceReady function, for the isDeviceSupported funciton, you should use functions that are actually defined in the rest of your code.

app.wikitudePlugin.isDeviceSupported(this.DeviceSupportedCallback, this.onDeviceNotSupportedCallback); 

The functions, marked red, do not exist in the rest of your code.


Please have a look at our sample application at The following snippet impl. a valid onDeviceReady function.

onDeviceReady: function() {




        // check if the current device is able to launch ARchitect Worlds

        app.wikitudePlugin = cordova.require("com.wikitude.phonegap.WikitudePlugin.WikitudePlugin")

        app.wikitudePlugin.isDeviceSupported(app.onDeviceSupportedCallback, app.onDeviceNotSupportedCallback);


    // A callback which gets called if the device is able to launch ARchitect Worlds

    onDeviceSupportedCallback: function() {

        app.isDeviceSupported = true;



    // A callback which gets called if the device is not able to start ARchitect Worlds

    onDeviceNotSupportedCallback: function() {

        app.receivedEvent('Unable to launch ARchitect Worlds on this device');



Besgt regards
Login or Signup to post a comment