Start a new topic

Targets Loading Improperly

Targets Loading Improperly

This is driving me absolutely crazy. I am test driving the SDK for possible inclusion into an In-House app. Normally the fact that I am posting to find a solution on the developers forum would turn me off of the product. However, for AR work, this is the best SDK for our development group to work with.

I am developing for iOS7, am testing on a iPhone 5. I have the latest Example code from Github that fixed the previous issues.

The example code works great, until you start to make minor tweaks to include your own targets etc. 

I uploaded my own images to the Target Manager, and created my own Target Collection. I ensured that it was properly reference within the project. I also have modified the js code approriately to use the new target collection, as well as the Target ID.

i.e. - this.tracker = new AR.Tracker("assets/", {

             onLoaded: this.worldLoaded





var pageOne = new AR.Trackable2DObject(this.tracker, "africa", {

        drawables: {

               cam: overlayOne




However when selecting the Image On Target, it does nothing but perpetually load. It will not read the target whatsoever. Whats even crazier to me, is that when I change it back to the original target collection and target ID, it will read and work perfectly. 



Hi Timothy,

So your problem is that your tracker file can not be loaded?!

have you tried to set the onError callbacks, so that you can get informations if there is something going wrong, loading your tracker file?
You can also enable our own console, calling AR.logger.activateDebugMode();. You typically call this function right before any other js calls are made. From now on, the SDK will print messages into the console when there is something going wrong.

Best regards


I have tried your suggestions. The onError callbacks are not being reached, so the tracker is loading properly.

The AR.logger.activateDebugMode(); also shows no errors being generated. 

The image that the tracker is tied to was given a three-star rating on your tracker manager. Not really sure what is going on. This AR looked to be like a flawless plug and play.

If this has something to do with running in iOS7, then I cannot roll back the os to an older version due to project constraints.

Since you was saying that the tracker was not loading, I thought it has something to do with your tracker file.

Does the onLoaded trigger on your Tracker is called?
When the onLoaded trigger is called on your Tracker,  the only place left for issues is the target name. It has to be the exact same name as specified in the Target Management Tool. 
If this still does not fix your problem, maybe the drawable is not attached correctly? Are you using the same code to attach drawables as in the sample?

It shouldn't be an issue with iOS 7.

Best regards

The onLoaded trigger for the tracker is being called. I added that in when you suggested the onError.

The names match exactly, as displayed in the Tracker Manager.

I am using the straight sample code provided, and am literally just trying to place my own tracker collections and images into the sample to test the SDK's ability to be used for our needs.

Could you upload or send us your target image and .wtc file? We can then have a look at it and give you individual feedback.

Best regards


Sent it to the email address.

I appreciate the help.



Hi Timothy,
Did you received our answer?

Best regards
Login or Signup to post a comment