Start a new topic

POI Labels going missing

POI Labels going missing


Hi,

I am trying to add multiple POIs (31 to be exact) to my AR View via the script. Each POI is a complex combination of AR Images and Labels. The odd thing that is happening is that when I launch my AR View, the text labels of some random POIs just don't appear. At first I thought that they were too complex to render so fast, so I added a 1000ms delay between the push of each POI onto the screen. However, this doesnt seem to have fixed my problem. The script seems to be randomly missing out adding some labels to the screen. Any idea what I could be doing wrong? Or any suggestions on what I could do to avoid this. Thanks!

P.S This is urgent, quick replies would be greatly appreciated. Thanks.

To make sure that the text is not hidden behind another drawable, you should set the zOrder of each drawable accordingly. Have you done this already?

If so please provide us with more information:

Do you see anything unusual where the text should appear? A screenshot would help. 
What platform are you running it on?
Is this happinging to all text after the first text disappears?
As always a code sample demonstrating the problem would help immensily.

Hi Wolfgang, Thanks for the prompt reply. The zOrder has been set for all drawables. Im running this on iOS 7. This is not happening to all text. I just realized that wikitude was throwing the following error - 

ARchitect: Texture memory exceeded!ARchitect: Texture memory exceeded!

I read another post where you explained that this could be because of creating too many image resources. So I made sure to create all my image resources globally just once. At the moment I am using only 5 resources, but I'm still having this problem and its still giving me the texture memory warning. And I still do have about 20  more unique images for which I will need to create the image resources. Any suggestions?

I have created the imageResources as follows -

        World.room_green = new AR.ImageResource("assets/room_green.png");

        World.room_gold = new AR.ImageResource("assets/room_gold.png");

        World.room_pink = new AR.ImageResource("assets/room_pink.png");

        World.room_red = new AR.ImageResource("assets/room_red.png");

        World.room_purple = new AR.ImageResource("assets/room_purple.png");

        World.room_blue = new AR.ImageResource("assets/room_purple.png");

And accessed it as follows

 

        this.markerDrawable_idle_type0 = new AR.ImageDrawable(World, 3.5, {

                                                              zOrder: 0,

                                                              opacity: 1.0,

                                                              horizontalAnchor : AR.CONST.HORIZONTAL_ANCHOR.LEFT,

                                                              onClick: Marker.prototype.getOnClickTrigger(this)

                                                              });

This last bit of code is called more than 30 times for each of the POIs I mentioned earlier

Depending on the actual size of the images, this should not be that big of a problem. Just to be sure check the size of the images, I would suggest trying a size equal or smaller than 256x256. How many AR.labels are you creating. Make sure that any AR.Label not longer required is destroyed by calling its .destroy() function. The function frees up the texture memory used by the label.

I'm also interested in the number of labels and imageresources you are creating and the exact sizes of the images.

Hi WolfGang,

Your idea of too many labels hit the nail on the head. I reduced the labels on the poi and all remaining labels appeared fine. The problem is that I need the labels I removed. The thing is I read on one of your posts that AR Labels donot support multi line. I have some text on the POIs that needs about 3 lines. So I had separated my string into 3 parts and created 3 correspinding labels. This is what was leading to too many labels. Is there any other way I can have a single multiline label?

I tried using an HTML drawable to create that multiline text. So basically each marker was a hybrid of HTML and AR Drawables. But it seems HTML drawables donot accept a zOrder lower than AR drawables. The HTML drawable I created was overlapping all other AR Drawables including those on other markers. Nothing I did could ensure that the HTML drawable didn't come in front of other markers even those further away than the current one. Any idea on this? Is it a bug in the HTML drawables?

Thanks for all your help.

P.S I know you asked for screen shots but since the POI design is confidential we have been asked not to share screen shots. Sorry I have to describe everything.

How many POIs are you loading. Would it be possible to limit the number (e.g. in Wikitude we are displaying 20 to 30)? We have seen that too many POIs on screen at the same time result in bad user experience as the user is overwhelmed by clutter.

Ultimately we want to improve the situation on our side, but we do not have a release date for this.
Login or Signup to post a comment