Start a new topic

device not supported

device not supported

1 person has this problem


Hi There,

These are what I did:


cordova create hello com.wci.hello HelloWorld

cd hello

cordova platform add android

plugman install --platform android --project ~/Development/AR/hello/platforms/android --plugin https://github.com/Wikitude/wikitude-phonegap.git

Copy PluginSamples/www (Download from GitHub) to hello/www and hello/platforms/android/assets/www

Change AndroidManifest.xml to 
<uses-sdk android:minSdkVersion="8" android:targetSdkVersion="19" />

cordova run android

When the App was running on Google Nexus 5 device, the jquery mobile interface was displaied but it still show me ?Device is not supported?


Thank you very much!

Hi Eugene!

Sample App works as expected on our Nexu 5 devices with Android 4.4.2.

Could you please try using "android:minSdkVersion="10" android:targetSdkVersion="17"" and let me know the phoneGap version you are currently using?

In case even this does not work please check out the provided sample project on github

https://github.com/Wikitude/wikitude-phonegap-samples

and let me know if it works for you.

Kind regards,
Andreas
Hi,
I am also facing the problem on Samsung Note II, getting message "Device not supported error". In the developing countries we most of the folks will have smartphones that came into the market in late 2012 and early 2013, so we can't expect people to have Samsung S4. Where can I get the complete list of devices supported? Also how do I support Wikitude IR in Android phones using Android 2.3 to Android 4.0?

Regards
Deepak

 


Hi there!

Not sure if your set-up is done properly or there is an issue in the sample app.
Could you please try the PhoneGap sample-app provided sample app. Android 2.3 devices are currently supported, although NEON chipset is required for ana cceptable IR experience (part of the isDeviceSupported check)

Especially devices like Note II are definitely supported by our SDK, so the isDeviceSupported check should return "true".

Please describe your issue in more detail and let us know where exactly the root of the problem is.

Kind regards,
Andreas
Hi,
 I am also getting problem for device not supported issue. now i am using phonegap for worklight enviroment. my application supported all android and ios device working fine AR. but i can not able to run the app in android device tap3 4.2.2 version.and i try to upgrade sdk. i am gettting lot of issue. how to upgrade sdk and how to solve this issue. anyone please let me know ASAP.

Thanks
Karthik
Login or Signup to post a comment