Start a new topic

Not able to run the samleArbrowser project on device

Not able to run the samleArbrowser project on device


I'm trying to launch the SampleArbrowser project on my device but everytime I got the "minimum requirements are not fulfilled " toast, on the other side i got the wikitude application and it works fine on my device.

My device is a huawei 8180, android 2.2. What is the problem?

Thank you.


the requirements for running the Android SDK are:

Android 2.2, SDK=8 (but running way faster on Android 4+ )


GPS and/or network positioning


Rear-facing camera

OpenGL 2.0

Can you check that your device is fulfilling each of the above requirements?

I tried the wikitude sdk 1.1 and it works .

Is it possible to use wikitude sdk without wikitude application?

The Wikitude SDK does not require Wikitude app to be installed on the same device. 

You say that Wikitude SDK 2.0 is not running on the device, but Wikitude SDK 1.1 is?

I found this information in the tutorials on the net that the wikitude application must me installed.

Yes wikitude sdk 1.1 works and not 2.0.


Have you checked all the requirements from above for your phone?

I just removed the wikitude application and tried the project with the wikitude SDK and I got this message : " wikitude was not found on the system. Please press the ok button to access the android market and download wikitude " . So it is necessary to have wikitude on the device


can you confirm that you are using the Wikitude SDK 2.0 and not the deprecated Wikitude API? Please make sure to download the SDK from the Download section above and use this one. The error message very much looks like you are using the deprecated Wikitude API.

The version i'm talking about is the SDK 1.1 not 2.0


please note that the Wikitude API is not the same as the Wikitude SDK.

Wikitude API 1.1: required Wikitude to be installed on the device (is deprecated since Mar 2012  - also support for this API in Wikitude app has been stopped)

Wikitude SDK 1.0, 1.1, 1.2 and 2.0: works as standalone library to be embeded in your application 

Your way forward is the Wikitude SDK.

Ah ok, thank you

Is there any tutorial to use the SDK?

Hi - have a look at the documentation included in the SDK and the tutorials you can find here:
Login or Signup to post a comment