Start a new topic

Many Compiled Errors

Many Compiled Errors


Are you trying to build the project for the iOS Simulator? That will not work. QCAR is not available for the simulator.

Best regards



In your project settings, Summary tab, add 'libc++.dylib' to the Linked Framework and Libraries section.  This fixed what I think is the same issue - manually upgrading a phonegap-based project to Wikitude 2.0

Hi Julien,

I encourage you to start a new project from scratch following both phonegap and wikitude get started guides.

Then try again removing arvm7s from valid architectures.

And im still using these "Other linker flags", you could copy and paste it.

-weak_framework CoreFoundation -weak_framework UIKit -weak_framework AVFoundation -weak_framework CoreMedia -weak-lSystem -ObjC -lsqlite3.0

hope it helps.


Thank you but not work yet :/

Hi Julien,

Try to remove the arvm7s from the Build Settings > "Valid Architectures".

Hope it helps,

Best Regards,




I have exactly the same problem.


IOS: 6.1


XCODE: 4.6.1

Wikitude SDK: 2.0 (26.02.2013)

MacBookPro: 17" retina

iPhone: 4S


did you already updated to our SDK 2.0? It now ships as a framework, so it's easier to add to your project.


Best regareds


Doesnt work...

here is what i did, according to your instructions:

I remove every search paths related to sdk, i found one that was still pointing to my test with vuforia and remove it too, remove the reference to sdk, and add it again with drag an drop.

i've noticed a difference between the HelloWorld Project and my Project: the color of the class name is different, i think it indicates a good link reference to the class and the other a broken link.

I have a newly created from scratch project not working, may i send it to you?

tks a lot.

If you added the SDK with drag'n drop, you don't need to add the search path yourself. Please remove all library search paths regarding the sdk and also remove the sdk from your project. After that, add the sdk with drag'n drop and try it again.

Best regards


yes, drag and drop, added search paths, everything, minusciously and i have started one from scratch, and got the same erros.

it means that i'm doing something wrong that i cant wonder.

may i send the "from scratch" project for your apreciation?

tks in advance


have you added the wikitude sdk per drag'n drop and also added library search paths for it, that could be the problem. 

You either need to add library search paths and linker flags for the sdk, or drag them into your project.

Best regards


 79/82 erros are connected to the libWikitudeSDK.a when it is referenced in the "Link Binary With Files" section.

i remove the reference for to the vuforia it was not helping.

I've tried to remove all sdk, and add one by one.

i spent my all day with that. :P

In the other hand i tried the "hello world" separetedly and it works. Do you think that could be the cordova 2.3.0 ?


Hi Andreas,

Yes, im using phonegap and xcode 4.6.

I've tried your instructions, but didnt take any effect on errors.

Attached a new image with more information...

an image with library search paths and other one with your new infos applied.

Any other idea?


Am I right that you're using PhoneGap?

Which version of Xcode do you have installed? 4.6 is the current available version.

I think you can delete the force_load statement and replace -Obj-C with ObjC. Xcode 4.5+ should be able to link everything correctly then.


Best regards


Hi Andreas,

Thanks for your reply.

I think I did.

Plz check the image (linker-flag.png) i've attached:

There are a new information that could help found the problem: when i run using simulator i got about 20 erros more than running with the device. i 've added the images.
Login or Signup to post a comment