Start a new topic

Unable to load POIs in WTSimpleARBrowser Sample.

Unable to load POIs in WTSimpleARBrowser Sample.


I was able to run ARBrowser sample project provided with wikitude SDK and could see POIs in ARchitect World till last week.

But, now i tried re-run it and  its not showing any POI.

Sometimes it shows 1-2 fixed POIs after lanuching camera view, but POIs appear to be stuck in the View/Screen.

It does not show any other POIs in the surroundings except for the ones those are stuck on the screen. 

This gives a camera view as if the screen is static with some POIs stuck on it.

I am using trial version of the SDK 1.1

Is there any validity for this SDK trial version?

Please help me in this regard.

Thank you in advance.

Kishan Lal

Hi Kishan,

if the POIs are stuck on the screen, probably the magnetometer on the device is not calibrated.

Can you please try to calibrate the compass (by moving the phone in as many directions as possible)?

Best regards,


Hi Martin,

Thanks for help.

I tried it by moving the phone in as many directions as possible, but the problem still persists.

The same code is working fine on other device.

Is there any setting in iPhone through which i can make the magnometer to work properly?

Or should i reset my iPhone to do this?


Kishan Lal.


please restart your device. Sometimes the Magnetometer stops working properly (Any other App which uses the Magnetometer stops also working properly).

Best regards

Login or Signup to post a comment